Hidden geometry still visible after hiding

Hello!

Amateur / hobbyist here. I worked on a model, and a bunch of hidden geometry lines started showing up, to an extent that I am unable to continue due to the messy look.

I clicked the eyeglasses “Display” button on the right and unchecked all the boxes. No difference, those messy part lines are still here…

What am I doing wrong? :face_with_spiral_eyes:

Tap k, it is the toggle for bacK edges.

1 Like

Holy cow… it worked… thank you !