Sudden hidden lines appear

first time poster.
I’ve encountered this for the second time now. I’m working away & suddenly it looks like all of the hidden lines are on. However Hidden geometry is confirmed off. Undoing the last command doesn’t do the trick, they’re still there.
model attached,

This happened to a different model last year on a different laptop.
SU pro, 2020
Any assistance would be greatly appreciated.

Davids Casa model. SU help.skp (9.2 MB)

Looks like you hit K to turn on back edges. Hit K again to turn them off.

By the way, you might consider erasing guides once they’ve done their job. Make sure you are using tags correctly…
Screenshot - 2_12_2021 , 1_15_33 PM

All edges and faces should be untagged.

And purge unused stuff once in a while.

Screenshot - 2_12_2021 , 1_07_35 PM

holy cow!! thank you!

1 Like

thanks, will clean things up.