Hidden geometry not working the same in SU2015


#1

I have been using SU since 2008. Recently I have updated to SU2015. In previous versions, I was able to create scenes where some things were hidden in certain scenes but not others. I just tried this today with a new model, and when I hid the roof of my house in the 9th scene, all the other scenes then no longer contained the roof! I was unable to restore the roof using Unhide All (which worked in previous versions). I finally had to open the house component to unhide the roof.

Through some convoluted combination of steps that I don’t quite recall, I was able to get a scene with the roof hidden, but all the other scenes have it still showing.

Can someone explain to me what the intended behavior is for this? If I have created scenes with the roof showing and saving “Hidden Geometry” properties in each scene, then why when I hid the roof on the last scene did it become hidden on all the previous scenes?


#2

Put the thing you want to hide on a layer and hide the layer in that scene. If you hide the geometry it is actually hidden.


#3

I don’t think this behavior is new to 2015. You can save the value of the view->hidden geometry flag with a scene by checking the box on the scenes window, but you can not save the current hidden/visible setting of individual entities. As @Box wrote, use layers if you want granular control of visibility instead of global.


#4

you can not save the current hidden/visible setting of individual entities.

Maybe that’s the way SketchUp is designed to work - I don’t know. But if you look again at what I wrote: “I was able to get a scene with the roof hidden, but all the other scenes have it still showing.” You can see that SketchUp is not working the way that you say.

So it doesn’t work the way I thought it would, and it doesn’t work the way you thought it would. Hence my question: “Can someone explain to me what the intended behavior is for this?” Can you point me to some documentation / tutorial video that explains the way it’s supposed to work? Or is this a bug where SU is not working as designed?

Thanks.


#5

Well I’ll be dipped! SU2015 does work as you describe. The visible/hidden state of each entity is part of what can be saved with a scene and can differ from scene to scene.


#6

[quote=“slbaumgartner, post:5, topic:11233, full:true”]
Well I’ll be dipped! SU2015 does work as you describe. The visible/hidden state of each entity is part of what can be saved with a scene and can differ from scene to scene.
[/quote]Only top level entities act this way. Geometry (nested) inside groups and components won’t respond in such a way. Best to controle visibility with layers and use ‘Hide’ just for temporarily hiding when modeling.