Help With 3D Connexion Space Mouse


#1

My Space Mouse wireless changes axes on me every time I save my model! When I first open the model (a house) I rotate, the model and it spins on the screen, staying centered. If I hit “save” and then rotate the space mouse in the exact same way, IT CHANGES ROTATION AXES AND STARTS ROTATING AROUND THE RED, BLUE, AND GREEN INTERSECTION (the origin). It is infuriating to say the least. Anyone else experienced this?

I have re-installed the driver on the space mouse. Never had this issue until I downloaded Sketchup 2017. Please help!!


#2

That’s crazy! Have you reached out to 3DConnexion? Their support is very responsive and they are likely to have an idea of how best to address the issue.


#3

Cool, Ill try that. Thanks, it’s driving me cray!


#4

I have noticed that it doesn’t stick with the default that you set, it’s very frustrating. Each time I open a model now I have to go into the preferences and change it to my prefered “Helicopter” mode.

This is new behavior


#5

This was a bug in the previous version. If you go to their site and get the most recent release, it should fix that issue.


#6

Aaron you’re a good 'un. I only installed that driver very recently!

It worked!


#7

I only know because I had the exact same issue!


#8

Ok, so I contacted both 3D connexion and SketchUp. SketchUp’s position is that because it is a 3rd party device and driver, they cannot determine the problem and therefore cannot help me. 3D connexion has been responsive, but I am still waiting on their thoughts.

I have noticed that when the 3D mouse switches axes, my regular mouse still performs normally. This leads me to believe that the problem is with the 3D connexion mouse.