Help needed with Upright Extrude not working as expected

I’ve used @eneroth3 's Upright Extruder very successfully in the past, but this time it isn’t doing what I expect, and I can’t see why not.

I’m trying to extrude a rectangular U-shaped channel along a curved series of edges.

I selected the face, and all the segments of the curved edges.

Instead of extruding the channel upwards, It just offsets it sideways.

If I weld the segments into a curve using TIG Weld, I get the same result.

If I move the face so one corner is at the end of the (welded) curve, and try again, it does this time extrude, but with a weird twist which renders the result useless.

I know from a previous post and reply from the author that Upright Extrude doesn’t work with faces that have holes, but this isn’t the case here.

Any idea what’s going wrong?

An ordinary FollowMe works as expected, but rotates the face which I don’t want - I want the extruded face to stay horizontal, not like the top of the result of FollowMe.

Here’s the SKP file, if anyone would like to try it.

Upright extrude.skp (76.4 KB)

The documentation doesn’t say anything about which directions the plugin might be limited to, andI I’ve used it successfully with other similarly oriented curved edges to extrude along.

How did you draw the curve? It’s very slightly out of the red/blue plane. After fixing it and moving the profile to the appropriate location, Follow Me does what I would expect it to do.

It was the edge of a face (which displayed as a singe face) originally drawn programmatically with Ruby and in plane, but perhaps since slightly distorted by subsequent manual edits.

How did you fix it? Indeed, find which line was out of plane?

I just tried it again with another face less likely to have got distorted, from the same ruby program. It behaves the same way - a 90° twist in the first segment.

I redrew the bottom segment dead vertical on blue. When I’d done that, the edge will offset, which I didn’t think it would if the curve was out of plane.

And it STILL twists 90° in the first segment when I do it using Upright Extrude.

FollowMe has always worked properly here even with my original curve - it’s the Upright Extrude that isn’t doing what I expect.

When I draw a rectangle perpendicular to green axis from top to bottom of the curve, the rectangle splits into two - so how can the line be significantly out of plane?

Both that, and the fact that the offset tool works, suggests that the problem isn’t in the curve, it’s in the Upright Extrude plugin logic, which I’m sure is generally excellent - but not working here as I expect.

I found it was out of plane by setting the units to mm and precision finer than you have it and setting coordinates at the ends with the Text tool. I then used the Rotate tool to rotate it about the red axis and then around the blue. The rotation angle showed as ~0.0 degrees. Had it been on plane, it would have showed the rotation as 0 degrees.

Maybe there’s something wrong with the Ruby script or maybe something wrong in your setup before running it.

You know, there’s a little 0.848674mm giblet stuck to the bottom of that path?
Is that supposed to be there?


THAT must be the problem - I didn’t see it.

Busy now with lunch, but will try again soon.

Well, that wasn’t the solution either, though I’m sure it contributed to the problem.

I think I’ve worked it out now.

AFAIK, Upright Extrude seems to determine the plane and hence (in this case) the x/y direction of the extrusion from the first two edges only.

And (as @DaveR pointed out earlier, the path isn’t quite exactly in the red/blue plane. So the plane calculated from the first two near-vertical edges isn’t well determined.

When I had got rid first of the little nib running approximately along red, and ALSO deleted the first two edges and started the extrusion on the third, it worked as I expected and wanted.

Thanks to you both for contributing to understanding the problem, then fixing it.

I wrote this plugin very long ago and don’t remember its exact workings. However it is based on the assumption that the extrusion profile is in a vertical plane. Having the profile in a horizontal plane can produce strange results.

1 Like

Thanks very much for replying, Cristina.

The trouble was with my curve. The plugin worked fine in the end with the face horizontal, once I deleted the first two edges in my curve which were both very nearly vertical and at a VERY small angle to each other too. And as Dave showed, not quite in the red blue plane, either.

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.