Should Upright Extruder Work With Sketchup 8?

To investigate this tool and keep things simple, I’m attempting to extrude a vertical disk that’s perpendicular to the xy plane along a single line that runs through the disk’s centre. However when I select the line and disk and click on the extrude tool, the status bar tells me to “select face and welded curve first”? Do I need to do something to the path to make it a “welded curve” and compatible with the extension?

If by disk refers only to the circle, you will need to select the face, as specified in the message.


1 Like

I have selected both face and line but the tool does nothing, just tells me to “select face and welded curve first”. If I select just the face, and click the tool button, it tells me to select one or more connected edges to extrude along. If I then select a path it and click the tool, it deselects the face and tells me to select a face.

As you can see in the animated Gif, I used SketchUp 8 and Upright Extruder from JHS Powerbar, I selected the path and face and it worked.
Are the circle and the face a group or are they just raw geometry?

1 Like

Just raw geometry. I’ve also tried with rectangles and polygons created using the line tool. This is what happens when I click on the Upright Extruder tool button after having first selected the face and line. It asks me to “select face and welded curve first”.

From various tests I have noticed that if the path is oriented on the Z axis, upright does not work. If I tilt it just a little bit, then it will work.

Have you changed the axis orientation in any way? I see that you have the path oriented along the Y axis, what happens if you rotate circle and path 90 degrees, to be oriented on the Z axis?

1 Like

No, I haven’t oriented the axes. It’s still giving the same message when the path is perpendicular to the xy plane. I’ll try it with the path off vertical.

Exact same response with the path tilted.

Then you have a few options:

  • nicely ask Christina (eneroth3), the author of the plugin, to help;
  • if it’s just for this simple task, you can use PushPull or Follow me;
  • or use a newer version of SketchUp.
1 Like

What do you get with this model when you do exactly what I show?
upright extruder test.skp (16.7 KB)


It does seem kind of silly to use Upright Extruder to extrude a circle along a staight path, though.

1 Like

Nothing happens when I press the tool button. It still says “Select face and welded curve first” before I click and “Ready” after clicking.

Are you selecting the curve and the face before getting the tool?

Try running the tool outside of the JHS Powerbar.

I’m highlighting the shape and curve by drawing a box around everything (I can’t see the box, but that’s another story and an issue with hardware acceleration and my graphics card). Should I just select the path and face without the surrounding outline?

It doesn’t matter if you select the face’s edges are not.

Did you try running it without using JHS Powerbar?

Why is it you’re using a version that hasn’t been supported for almost a decade?

I downloaded the standalone version and it seems to work fine now, doing what it’s expected to do.

Sketchup 8 can be used for commercial use according to this. Newer versions require a licence for non-personal use. I just want to use it for the occasional illustration in online guides. I could install a more up-to-date versions for some DIY projects at home, although what I’m using is good enough.

So in SU8 at least it’s JHS Powerbar that is the problem.

1 Like

Seems so. Anyway thanks for the perseverance in the troubleshooting. :slightly_smiling_face:

1 Like