Upright Extruder plugin produces unexpected result


#1

This has generally worked brilliantly for me, but a recent extrude of a long large face with window openings in SU 2018 lost the openings. It did the same in SU2016.

Since 2018 isn’t working well on my 5-1/2 year old laptop upgraded to Windows 10 I’ll upload the v2016 file

Upright Extrude failure.skp (189.8 KB)

image

The window openings disappear in the extruded face. It’s a 1ft extrusion of a face several hundred feet long, which will PushPull - so I think it’s a single face with correctly formed openings.

But I wanted it extruded along green, not perpendicular to the face.

Christina (@eneroth3), I tried to post this as a comment on the Extension Warehouse, but it was rejected as potential spam.

Can you see a reason for the extension to fail on this? I’ve used it before, on quite similar faces in the same large RiverArch model and it has been extremely useful.


#2

Hi John

The upright extruderdoesn’t support faces with holes in. However since you are just extruding along one single edge you can use push pull and move to achieve the desired result.


#3

In the end, I did just that. It hadn’t worked earlier, but in a new model with a clean copy of the face, it worked.

I hadn’t realised that Upright Extrude doesn’t work when there are holes in the face. Thanks for the explanation.


#4

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.