HELP Layout won't open

I’ve uninstalled and reinstalled. I’ve reset the comp, I’ve done nearly everything! Has anyone run into this?

Are you trying to open a file or just open a new file?

We are have tried both

Reinstalling won’t take care of the user specific files in the ~\library/Application Support/SketchUp/SketchUp 202x/LayOut

Try to rename that folder and then start LayOut

@MikeWayzovski This does not work, it only creates a new layout folder and shoots me the same error

1 Like

I copied the error into AI and it told me its possibly an OS conflict… I have been unable to open layout… I cleared caches, I reinstalled, I opened it via a viewport and just a plain document. this error is holding up my projects at this point.

1 Like

When did Layout most recently operate successfully? What of significance has changed on the computer between then and now?

1 Like

What is the OS version?

Ventura 13.5

this was happening to a coworker last week. She turned her computer off for the weekend and it now operates. She dealt with this error for an 8 hour work day.
This error effected me this Morning, it was working yesterday before i shut my computer off at the end of the day. I started the computer up this AM and I was getting this error.

No updates were made between layout working and not working on both systems.

Thanks for the background information. Interesting that multiple computers are affected, but somewhat differently. In your co-worker’s case, do I understand correctly that turning off the computer resolved the issue? Rebooting your computer has not resolved your similar issue.

Something must have changed! :slight_smile: Is macOS set to perform automatic updates when they are available?

I have turned the auto update feature off because of these problems. The long term reset seemed to help my coworker (don’t know why?). I’m very strict on what software/updates are allowed to run on my machine. That being said, it’s possible, but very unlikely that any software ran during the night or at startup. If something changed it slipped through my radar.

I have rebooted and left it off for an extended period, didnt work

There’s been no recent change in SketchUp or LayOut 2023. Fundamental troubleshooting technique is to look at what has changed in the system since the application last worked.

Yeah, I hear that, I’ve put everything through the ringer… It’s probably Apple TBH, I’ve noticed the last few updates have had compatibility issues with sketchup/layout… I’m at a loss and praying to the software gods that it resets overnight

– heavily edited post –
pretty sure my crash was due to the change of username that I did this weekend right before updating to 13.5

so it’s not related to the situation here, I didn’t even get the osX crash message Keene got, but a regular bugsplat.

Crash #3130

My crash was happening right before the 13.5 update… i updated to 13.5 to see if it would fix it, but it did not help.

I guess I wouldn’t be too surprised that there’s issues. 13.5 was released on July 24. It’s not unusual for Mac OS updates to break applications. We see these sorts of things frequently. Might want to roll back to the previous OS version until Trimble can make the needed updates to support 13.5 and release them.

whats strange about this crash is that I was operating as usual, it wasnt the most recent update that caused it. I updated to see if it would fix the issue

Did you get a Bug Splat when LO crashed before you updated the OS?

Still, there must have been some change on your computer to cause this to suddenly start.

No bug splat, it was working fine yesterday, shut my computer off and this morning, stopped working. Tried the update to see if it fixed but no. My error is an OS error, not a sketchup bugsplat error.