Help! I need to reinstall Sketchup Pro 2018 from Scratch


#1

Help. I’ve just bought a new computer and installed Sketchup Pro 2018. Sketchup seems to work fine. Then I install Maxwell 4.2 Renderer Extension. Maxwell installation failed on me, so I reinstalled it again successfully. Both licenses are valid. But my Sketchup started behaving badly. When I run in admin mode, Sketchup would work but I could not load the Maxwell materials. When I run in non-admin mode, Sketchup will bug-splat. Something is obviously wrong or missing. I’ve tried Sketchup repair. Same thing. I’ve tried reinstalled Sketchup. Same thing. Curiously, it did not ask for license yet the license still shows up. How do I start from a clean slate again for both Sketchup and Maxwell. It seems the uninstall left something behind.


#2

I have no experience with Maxwell renderer, but to facilitate a clean install of SketchUp (apart from reinstalling your operating system), you could try editing the registry (something I have done for many years, but quite risky for the inexperienced).

In Windows 10 you right click the Windows icon in the bottom left corner of your desktop - there will be a run option - left click, then type regedit and press enter.

You will then be in the registry (a lower level view of the operating system).

If this is something you wish to try, I can give further instructions to safely delete vestigial registry entries for SketchUp.


#3

Please do provide the instructions for editing the registry. I am going to try a few things before taking that final step. I thank you in advance for any help you can provide. I have other licensed software in the computer so I don’t want to completely wipe my HD. All these licenses are making it extremely frustrating to make all the software plays together. Again, thank you.


#4

Did you install/repair using the method that is recommended by experienced users?
Right click on the install.exe and choose Run as Administrator.
This is different to installing while logged in as an admin, or running the program as an admin.


#5

Hi Box,

No I did not run the program as an admin. I logged in on the admin account then install the application. As a matter of computer security policy, this is how I usually set up my computer: I created several non-admin accounts for myself and other family members. Then I logged in the admin account and installed all software applications. The admin account is used for this only purpose. So for everyday usage, everybody logged in as non-admin and use the computer. When there is a new application, then I will log in as admin and load the application. I don’t use any antivirus software except Windows defender that comes with Windows. In this particular instance. After testing for a while, it turns out Maxwell Render extension is the culprit. As soon as I remove Maxwell, things works as normal again. The only thing is, this is not the first computer that I have setup this way. Others computers (friends and relative) were set up with multiple non-admin accounts and worked as intended. I have other software that have licenses so when things like this happen, it extremely painful to re-setup the computer. I think I will have to ask Next Limit to see if they can offer some help. However, thank you for offering helpful idea. This is one of the most finest features of the internet. A community of folks with common interest helping each others. For my own education, could you please explain the difference between running as admin vs. log in as admin. I just don’t see why there’s a difference???


#6

Here you go.


#7

Hmm…interesting. It doesn’t explain the difference but thank you for pointing out there may be a difference. I may try it again. I will remove both Sketchup and Maxwell then log in as non-admin then install them by “run as admin”. This is very counter intuitive but I will try it. The reason for getting the software to work right is that, after the software have properly set up, I will make a duplicate HD using Samsung HD image copy. I always buy two identical Samsung SSD and will duplicate the main SSD with Windows OS and all apps from time to time just in case something goes horribly wrong then I will have a physical restore point. Windows restore does not work as promised and RAID set up will corrupt both drive as virus may infect both.


#8

Fair enough. I’ve managed since my first pc in 99 to cope with whichever hard drive my computer had, with a bit of a back up to another disk somewhere. Each to their own.


#9

Box,

Again, thank you. I will report the result if the new method will make a difference. You have been very kind to offer help. Have a good day.


#10

Ok, here’s the result: No different! I uninstalled Maxwell extension, then tried Sketchup in non-admin mode. It works as it suppose to. I then installed and activated Maxwell license again using “run as administrator” mode. License accepted and installation was declared successful. I then tried Skecthup again in non-admin mode: Bug Splat! I have done the installation on a couple computer and this has never happened before. This is a brand new i7 computer with Windows 10 Pro. I may have to mosey to the Maxwell forum and ask if anybody else has this problem. Thank you just the same again for the advice.


#11

What are the specs of your machine? Here are the hardware requirements for Maxwell:

http://support.nextlimit.com/plugins/servlet/mobile#content/view/39821613

And for SketchUp:

https://help.sketchup.com/en/article/36208

If planning to render, always go for recommended or higher


#12

Mike,

This is a very new computer. Here’s the spec: Intel Core i7-8700K Processor 3.7GHz; NVIDIA GeForce GTX 1080 Ti 11GB GDDR5X; 16GB DDR4-3200 RAM; 2TB HDD+480GB SSD. I don’t think it’s the hardware issue. Some how the Maxwell installation does not play well with Sketchup. I am sending a technical support request with Maxwell. Hoping to have at least a hint of what’s the problem may be.


#13

Sorry for the delay - I just saw this.

Bear in mind this has less than 50% chance of helping with your unusual issues. It is valuable in itself for clearing out residual software references to apps that have been removed from your computer in the past though.

Editing the registry (deleting SketchUp references) has a sliding scale of risk. The more you delete, the more obscure the locations and potential errors created.

If you search the entire registry, you may find a few dozen entries related to Layout, SketchUp, Trimble, etc.

Editing the first couple of entries only takes a few minutes.

After following my previous instructions, you will see HKEY_CURRENT_USER. Open the drop-down list and then the SOFTWARE list where you should see references to SketchUp and Maxwell. Delete the SketchUp and Maxwell references completely and nothing else.

Next, you will see HKEY_LOCAL_MACHINE Again, open the drop-down list and then the SOFTWARE list where you should see references to SketchUp and Maxwell. Delete the SketchUp and Maxwell references completely and nothing else.

That’s it. Shut down the registry and reboot.

If you want to do a more extensive registry edit, you have to do a search (edit_find) for key words such as Layout, SketchUp, Trimble, and Maxwell. Eventually, you can find references to the license, etc.

Windows 10 now has a feature called Fresh Start (a reinstall of Windows without deleting files (but most apps)
I tried it last weekend - took about 4 hours to complete with reinstalling apps and resetting the settings.
The only problem was edge favorites were lost and my backup was months out of date.

Computer and SketchUp are running better since (wipes out all old app references in the registry).

To do a fresh start - go to Windows Defender security center - Device Performance and Health - Fresh Start and follow the directions.


#14

All,

Thank you for taking time to offer me guidance. I really think you guys are really a bunch of finest peoples that are so willing to help a complete strange. Thank you!

As far as the problem goes, Maxwell Tech Support has resolved it for me. I am posting the solution here in case if someone may run into a similar issue in the future:

The issue arise as follows:
When a user checkouts a Maxwell RLM license, the logfile liclog.txt located at %programdata%\SketchUp\SketchUp 2018 is updated.
The default NTFS permissions on this file are set as follows
Administrator - Full access
System - Full access
Users - Read & Execute
"First user to run plugin " - Full access

As can be seen, such a permission setup would allow the “first user” to modify the log file, but any other user on the pc would only have read capability.

Therefore once a user request a license from the rlm server, the software tries to update the liclog.txt using the users credential, fails to do so due to ntfs permissions and causes the software to crash.

The resolution to the issue is to either
a) set the permissions of the “users” group to modify on the liclog.txt file
b) add permissions for the “authenticated users” group and set them to modify on the liclog.txt file (more secure option suitable for a domain environment.)

Once one of the following is done, the Maxwell plugin works fine and can obtain a license from the RLM server without crashing.


#15

GSTUDIOS,

Thank you for the guidance. I am saving the instructions for future references.