HELP DCs don't work for me at all

advice
import
bug
installation
hardware

#1

I’m new to DC’s and am considering buying pro if I can use them effectively for my construction business but…
None I download work
I’ve tried using the newest versions of sketchup make and an older version (8) which I have messed around with years ago and have installed now.
I’ve tried downloading different dynamic components from the warehouse none work.
When I click on component options it shows no options
This happens with all the DCs I download
When I try to scale them this happens

It’s supposed to fill in studs at the appropriate spacing’s ( I’ve removed the drywall and plywood for clarity)

Here is the component from the pictures but it happens to me with all of them so I don’t think it’s the component that’s the problem.
2 X 4 or X 6 dynamic wall assembly-1.skp (137.7 KB)

Also I’ve read that sometimes DC’s come with a wrapper that you have to open before they work properly this isn’t the case for me in fact they don’t even come as a component ( meaning when you click on one part the whole thing gets selected) that I can see.

I’ve been searching for an answer for weeks can someone tell me whats going wrong?


#2

There in lies the problem by the sound of it, you are inside the component.
Insert the component via the component browser or import it into another model and see if it works.