Having trouble with 2D fills

Perhaps I am too old school…I have been using SketchUp for nearly 20 years. When opening a new file from the Architectural template, I change the view to parallel projection, and set construction lines on the Red and Green axis. While drawing, I make sure that a line is showing that it is parallel to an axis when inputting a dimension. After creating an outline for an object, sometimes the intersections are apparently on different levels, and will not “fill”.

How do I keep all of my lines on the same plane?

Thank you!

Start by drawing a large rectangle and then create the edges on that. You can erase what you don’t need later.

The model space is still 3D even when you set the camera to Parallel Projection so that won’t prevent the edges from going out of plane. SketchUp was designed to be used wiuth the camera set to Perspective while modeling. Parallel Projection is intended mainly for output. With practice you should ffind it easy enough to keep edges on plane while modeling in Perspective.

Also make sure you are creating closed loops of edges and that you don’t have slight overruns.

And turn off Length Snapping in Model Info>Units. That will get in the way of precise modeling.

Great advice, I will give it a try!

1 Like

Maybe you know already this, but you can lock the axis so if you want to make a line parallel to the red (x) axis hit the right arrow, to the green (y) axis hit the left arrow and to the blue (z) axis the up arrow. It works also with rectangles, circles and any other polygon, but it works different, if you want to draw a surface on the red and green axis you must lock the blue axis and the same for the other axis.