Having trouble closing up an angle

Hello everyone,

So i am making something for my cnc machine and i am trying to close an object off an angle like the rest show.

if someone could kindly help i would appreciate it :slight_smile:

Is it a circular arc and two straight edges? If they are coplanar, redrawing one of the straight edges should close the face.

If it doesn’t, then possibly:

  • the edges aren’t co-planar
  • there’s a gap somewhere
  • you have some reversed faces (the shading in the image suggests that)
  • everything is too small: make the item into a component, copy it, then scale up the copy by a factor of 100 or 1000, redraw the copy, then delete it when done

And it would help if you can upload the SKP file (same process as to upload the image)

PS. What causes the fuzzy edges, and the short angled lines at corners?

thanks hope this helps

I’ll have a look in a few minutes when back at my computer (replying from phone now).

Two problems

  • the drawing is ‘full size’ which is normally correct, BUT Sketchup can’t handle very small lengths
  • the corner you are trying to fill isn’t co-planar.

To close it, you have to ‘hand stitch’ by drawing lines from the apex of the ‘triangle’ (where the two straight edges meet) to the end of each segment of the arc at the edge of the corner hole you are trying to fill.

So - to try it yourself, make a component of the whole thing, scale up a copy by x100 (use the Scale tool), ‘stitch’ the open corners, and see if you can get that to work.

If you still have problems, I might be able to try to do it for you, but not immediately - later tonight (UK time) or tomorrow.

PS. Your corner ‘arcs’ have exploded into edges, and probably have too many segments (20, in the corner I looked at). When you have scaled up a copy of the component, try deleting the edges, and redrawing an arc with fewer segments. Sketchup can’t really deal with edges shorter than a fraction of a millimetre anyway. Unless your machining or 3D printer is very precise, it won’t be able to make them, either, if this is to be manufactured.

i am able to do this but how do i make flush like above in the real photo

I’ve had a few minutes to try ‘stitching’ one corner, but without even scaling up.

It looks like this:

As you can see from the selected (highlighted red) edges, the corner ‘arc’ is very irregular - not a true ‘arc’ at all, with numerous edges of varying length.

Try redrawing the whole of this part of your model (the rectangle with rounded corners), to an enlarged scale.

Sorry, all I have time to try at the moment.file removed at the request of the author

Will this work for you?

It was easier to redraw the opening than to fix up what you had.

SKP file removed at OP’s request.

1 Like

Yes that’s perfect thanks so much!!. if you dont mind me asking how did you do it?:grinning:

@DaveR, you beat me to it!

I redrew the upper rectangle at 110mm x 92mm (it wasn’t an exact 92mm), drew two 6mm lines in each direction from one corner, then used the Arc tool to round them with 6 segments per quarter circle.

Then just double clicked in each corner again with the Arc tool selected, to repeat the corner rounding.

Push-pulled down 5mm, to get a parallel sided solid. Deleted top surface.

Selected bottom surface, used Scale Tool about centre (press Ctrl on Windows, or Option on Mac) first in X direction typing in a size of 98mm (= 110 - 2x 6mm fillet), then did the same in the Y direction typing in 80 mm for the size. That shrinks the bottom to a rectangle, and leaves the bottom in place (if you want that face).

BTW, the top left hand rounded rectangle opening isn’t quite parallel top and bottom in the original - see image from Top view parallel projection


And the whole thing is off-axis by 1mm or less at the bottom left hand corner.

I don’t have time at the moment to show you - but see if my description works for you.

I drew it off to one side first, as a separate element. You can then move it back, and delete any faces you want to get rid of.

Your original opening didn’t seem to be quite flat and/or parallel sided, so I started over with a new rectangle drawn in Top view on the red-green plane, to make sure it was dead flat.

DaveR might be able to show you how he did it, but I’m sorry, I have to go now.

I did it a little differently from John’s method.

First, I made a component of your model, made a copy of it and scaled that copy up by a factor of 1000. That scale factor is arbitrary but I just wanted it large. Next, I opened the large copy of the component for editing and deleted all of your geometry for that hole. This renewed the faces on the top and bottom surfaces. Then, before adding more geometry I used ThomThom’s Solid Inspector² to clean up a bunch of internal faces and other things preventing the component from being identified as solid. Then it was on to drawing the new hole.

I drew a new rectangle and put a 6000mm radius at each corner Remember the component is 1000x bigger than the real one. After completing rounding the corners, I used Offset to make an offset edge 5000mm inside the first shape. This offset distance equals the thickness of the piece so the the bevel is going to wind up being 45°. I choose a slightly larger radius for the corners so that the corners of the offset edges would also have a radius.

Next, I selected the face inside the offset edges and the bounding edges by double clicking on the face with the Select tool. Then I got the Move tool (M), held Alt to invoke Autofold and moved the selection down to the the opposite face. It all sounds much harder than it really is.

I closed the large copy of the component to get out of edit mode and then I deleted it. Zoom Extents returns us to the original copy of the component which I again checked for Solid before saving.

I think you would do yourself a favor if you would work with the camera set to Perspective. Even if you want parallel projection for exports, it’s just plain easier to model in Perspective mode.

Replying from phone again. Dave’s method (scaling up) is better when working with small edges. I tried using offset on your original outer rounded rectangle surface, but it wouldn’t form an inner face - something not flat or parallel in original