Having problems adding additional curve to face to expand area

sketchup
advice
modeling

#1

I have my cabinet 2D face selected here:

Then I add a new curve here:

And it doesn’t add to the area on the face. I also delete the internal lines so it then would “fill in” the external area drawn and it doesn’t work.

Here is my skp file:
Total Cabinet Combined.skp (2.6 MB)

Help would be much appreciated. I’m banging my head on the keyboard!


#2

Looks like the same problem you’ve had before. All the Y values should be the same but they aren’t. You need to keep all of the edges on the same plane in order to get a face.


#3

We both mentioned this before. Your side panel isn’t flat, as you can see all the extra lines with hidden geometry turned on.
The white one is flat and so has no extra lines.


#4

I redrew this with the specific point of keeping it on the same plane. Is there a way to prevent myself from leaving the plane?


#5

I’m very confused how you made the flat version from what I had.

I tried to lock the camera in PP and redraw it, but I still had this problem.

How did you create the white piece? I would love to know how to do that.


#6

It’s been mentioned before. Draw a large rectangle to work on and draw the outline of the panel on it.


#7

Yep, as @DaveR says, it’s best to draw it cleanly to begin with on a flat face, but you can get a flat profile by intersecting a face with the ‘profile’ of a shape with a non flat face.
Here I have a face and move it so it isn’t touching either face, only the ‘sides’ of the shape, and use Intersect Faces/ With model to get the profile.
Your original has some rather messy curves in the corners, so you could redraw them to get a nicer finish while you are at it.
Flat


#9

Just to address the actual problem with your curve. As Dave pointed out it isn’t planar to the y axis, but then neither is the object you are drawing it on.
Remember you are drawing in 3 dimensions, so it is possible for the arc to move around very easily, you need to let it know what plane it should follow.
So as you make the bulge of the arc, use the inference of the edge you want it to be planar to.
You can see here how I follow the edge and how it is just slightly different to your original arc.
Arc%20Offline


#10

While it’s essentially the same as drawing a rectangle to draw on (as already suggested), you might try TIG’s “work plane” extension (if it works on your version) maybe it will fit/feel better for you? it will create a temporary surface to draw on to help constrain your work to that plane.

Also, the side panel isn’t square to the rest of the cabinet, if you turn on “axis by color” if that’s available in “styles” it will show those issues, this may be part of the problem you have too.

Also, (as another way to Box’s solution) if you don’t want to redraw what you have already done, you could select the single triangulated face (group it) lay it flat and use Eneroth’s “align to plane”, this will bring all geometry to one plane and you can then delete all the additional lines. Push pull that to your thickness and stand it up vertical again.

While these may work as "fixes’ to what you have, it would be better practice to try and draw clean from the get-go. Much like building real world items, it may be better for you to draw elements on the floor/a ground plane, to get your parts built and then stand them up and assemble? Sometimes when things are up in the air, they can be less manageable until you get the hang of it.


#11

My personal preference for creating flat objects is to use the XY plane (red/green axes) in plan view using Parallel Projection. Once I’m done, I can group things and orient them anywhere I want. The inference engine will consistently place new geometry onto one of the primary planes in a given view.

From the SketchUp User Guide:

Drawing Planes: SketchUp will snap to the planes defined by the Drawing Axes and your
view when it cannot snap to geometry in the drawing area. For example, SketchUp will draw
on the ground plane when the point of view is that of the ground plane.


#13

This worked great! thank you!


#14

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.