Have sketchup version 2020 pro - tried to download / install 2021 - but now nothing works

Hi Everyone - help please - im very tech challenged I am currently doing an online course teaching me how to use sketch up - and went to open a Zip file provided for me to work on and import into sketchup - but when i tried to open - i get a box on my screen telling me

This operation could not be completed since the model was created in a newer version of SketchUp. To complete this operation you will need to upgrade to the latest SketchUp version.

(i currently have 2020 pro) so i downloaded the 2021 version - but when i try to open the zip file - it now tells me that it can not be opened.

i have downloaded the latest version - but it still will not work

have contacted sketchup - but was told 24 hours ago they will get back to me asap…

Is anyone out there able to tell me what i am doing wrong - or what i need to do … in an easy (dumbed down for a non tech head) thank you

i am on a Mac

Can you attach the Zip file here.
Just drag and drop it into a reply window.

its saying the file is too big

Do you know how to use dropbox or similar. You can add the file then copy and paste the link here.

sorry its not working in dropbox - its saying something went wrong previewing this file

Try this.

sadly wouldn’t open… it tries… but just won’t

Well I have no idea, the file opens for me and I backsaved that to 2020, so it should open in 2020 for you.

One of the Mac gurus may be able to suggest a fix.

thanks for trying… i have no idea what’s going on :tired_face:

The example model uses Tag folders, and opening it in 2020 would lose those. So, the problem to solve is getting 2021 working.

Does SketchUp 2021 open ok, and can you make new models, save them, and reopen them?

Tell us more about the exact steps you went through to install 2021, be as complete and clear as you can.

1 Like

That’s Laura in the picture, and it tells you that you are in SketchUp 2020. To try opening the file, go into Applications, SketchUp 2021, and open SketchUp from inside that folder. Then open the file from inside SketchUp.

hi colin i have downloaded the latest version of sketchup - however still when i open sketchup the 2020 version continues to open - which does not allow me to work on my lessons - sketchup 2021 version is in my applications - im really not tech savvy - so unsure what i am doing wrong.

If you can’t go into Applications to open SketchUp that way, you can Get Info on any SKP file, and change the Open With option to have the file be opened in SketchUp 2021. There is a Change All button as well, if you want all SKP files to open in SketchUp 2021.

Going into Applications, SketchUp 2021, shouldn’t be too hard to try. You can get to Applications from the Finder’s Go menu.