Sketchup won't open

Hi everyone, I am using sketchup 2020 on a mac. For sometime now I cannot open sketchup by clicking the sketchup app. I have had to restart my computer everytime, which allowed me to open it once. This is how I’ve retrieved my recovered files (as it often crashes).
But now restarting doesnt even work, when i click on the app only a blank page opens up. I have some drawings in the recovery section I need to retrieve badly, can anyone help as I cannot get onto sketchup for support?

Your profile contains nonsense about your SketchUp version and OS. Have you recently updated MacOS? SketchUp 2020 won’t run on the newest few versions of MacOS.

HI @Tabla, thanks for the post and sorry to hear you are having difficulty with SketchUp. 2020 is not technically supported in an official capacity any more so we can not offer official support to you. If you are on the Pro plan, you should just be able to download the latest version of SketchUp and use that although you may need to reinstall any extensions you are using and we can not guarantee older extensions will work with a newer version of SketchUp.

Is there a reason you need to run 2020 rather than a newer version? If so, please let us know about it. We do our best to maintain SketchUp’s features so if we messed something up and your workflow is affected, we can always do our best to find a solution for you in our latest version.

If your profile is incorrect and you are not on the Pro plan, we can do our best to assist you as a community but we can not promise any solutions as we have not updated 2020 for a number of years as we no longer maintain that version.

Finally, please make sure your profile contains accurate information. We do our best to assist people but knowing accurate info helps us to help you faster.

Hi there

Thanks for all the Infos. So we had a life plan with sketchup so we just paid once and supposedly have sketchup forever.
What is the difference with sketchup pro?

Also, I’ve tried to download the 2024 version but it doesn’t work. I’ve deleted completely sketchup and tried on my brand new Mac book pro and it keep saying this message when I try log in :

My workload is completely affected as I can to find drawing that I’ve done and were ready to start production,

Please help.

Hi

Sorry what do you mean by my profile contain non sense ?

Ok good to know, but we’ve purchase sketchup at the time and we don’t pay monthly we only pay once and supposed to have it forever so I thought I had to only use the 2020 version? Also, I’ve tried to download the new version and deleted sketchup and they won’t let me logging neither on the 2020 and 2024 version that I downloaded again

Can you help?

Capture d’écran 2024-05-20 à 20.28.27

your licence is correct.
Your sketchup version should be 2020. not sketchup.
your Operating System is MacOs something, not 2020
your graphics card should be a graphics card, not memory. maybe an inter chipset, maybe a M1/2/3 something, maybe an AMD.

that’s what he meant by nonsense.

depending on what you write there, you’ll have different answers. maybe you have a M2 mac running os14 (sonoma) and therefore sketchup 2020 is technically not supported and could indeed refuse to launch or crash often. maybe you have a low end intel GPU and big files, explaining crashes again.

and we’re missing a bit of history here, when you say “for sometime now”, what happened at that time ? was it after an update (as Anssi asked) ? or changing your mac ? or your internet provider ?
Think of this forum as doctors, remote doctors. if you complain about headaches, it could be migraines. But if you mention you fell from a tree it could be head trauma.
information matters :slight_smile:


from what you wrote, you’re now using a brand new macbook pro.
If that’s the machine you’re trying to use sketchup 2020 on, with mac os Sonoma (14) on it, then I’m not completely surprised it’s giving you troubles.
Sketchup 2022 was the first version natively compatible with silicon chips, that is the new M1/2/3 CPUs in all the new macs.

There is something that I only noticed today. Older versions of SketchUp, including 2020, are showing a blank welcome screen. You can close that window and go to the File menu, and from there open any recent file, or start a new model.

The online features that need a sign in are mostly not supported in 2020 anymore, which means there may be no reason for you to sign in.