Sketchup 2020 crashes on startup on MacBook Pro M1

could not start my Sketchup 2020
any ideas_?

tech report preview printscreen
report

full report:

thank you

Was this the first time you tried? Did it work before? AFAIK SketchUp 2020 is not supported for MacOS 12.6. That doesn’t straight away say that it won’t work but…

When you tried opening SketchUp again, did you see a bugsplat window? If you do, can you send one of those into us?

Your awake time is exactly 1400000 seconds. That seems an unlikely exact number! I have seen issue in SketchUp before that seemed to be caused indirectly by not having restarted your Mac for a long time. In your case that’s over 16 days. Might be worth a restart to see if things improve.

Can you say in what way you are licensed to use SketchUp 2020? If you have a Classic license it would be worth checking to see if you were entitled to a 2021 license.

You are using SketchUp 2020 in Rosetta on an M1 MacBook Pro. For me, that seems to work ok, but it definitely isn’t in the list of supported platforms for 2020.

I am not daily user of Sketch up. This was for the first time since I’ve moved from my older MacBook to new one.

This is Report window screenshot after system restart.

I bought the licence on ebay in 2021
[Sketch_Up Pro 2020 | Full Version | Life Time Licence | MAC ]

The error seems to happen in various applications, not just SketchUp. I mean, not for you in particular, but there are a lot of reports about that same crash from other people who don’t use SketchUp.

In Finder, Go menu, choose Go to Folder… and paste in this text:

/Applications/SketchUp 2020/SketchUp.app/Contents/MacOS/SketchUp

When you see a window with SketchUp with a black icon, double-click on that. It will run SketchUp from Terminal, and that may expose more information about what is going wrong. When it has finished crashing, reply here with the last 20 lines or so of what is in the Terminal window.

Sketchup crashed again
here is info from Terminal window

Last login: Sun Dec 11 16:40:25 on console
slafko@MacBook-Pro-uzivatela-Slavomir ~ % /Applications/SketchUp\ 2020/SketchUp.app/Contents/MacOS/SketchUp ; exit;
zsh: bus error /Applications/SketchUp\ 2020/SketchUp.app/Contents/MacOS/SketchUp

Saving session…
…copying shared history…
…saving history…truncating history files…
…completed.
Deleting expired sessions… 11 completed.

So, that gave me a new idea. Did you get the new Mac going from a Time Machine backup of the old Mac?

Even if you didn’t, it would be worth deleting the support folder, and the SketchUp 2020 folder in Applications, and copy across a new folder from the 2020 installer image. You can get a new copy from here:

https://www.sketchup.com/sketchup/2020/SketchUpPro-dmg

The support folder is in here (you can use Go to Folder… to get there):

~/Library/Application Support

Instead of deleting you could rename the SketchUp 2020 folder in Application Support, that way if you have plugins you could copy them over to the new folder, once SketchUp is working again.

Look for a new private message from me as well.

Who was the eBay seller?

1 Like

Reading between the lines, I assume you went from an Intel Mac to a new M1 Mac and are attempting to run SketchUp 2020 under Rosetta?

The crash says there was a bus error. In brief, this means the code either tried to access a memory address that simply doesn’t exist, or tried to access a data object at an address that is not legal for that type (e.g. an integer can’t be read or written from an odd-numbered address). To me, especially given @colin’s note about this happening in other apps too, that suggests a serious bug in Rosetta, perhaps when it converts apps that do some specific kind of operation. You might try reporting this to Apple and see whether they have anything to say about it.

Usually, hacked versions of SketchUp have a somewhat different filesize than the original. You can check by downloading the official version.

You can also check what classic license you have here:

Or new subscription here:
www.myaccount.trimble.com

I have seen several that work on intel bases macs, but won’t work on M1 processors.
In general, SketchUp is obtained through sketchup.com or an official reseller or distributor.

Ebay offerings are usually fake.