Have lost my model, need ideas

I seem to have lost my model and hours of work. Looking for tips.

I was trying to draw some lines with simple angle to follow. I noticed the protractor wasn’t working properly. When I’d set an angle for a guide, the guide wouldn’t draw. I was working on a 6" 45 degree pipe component. Pretty simple stuff. Then suddenly everything disappeared and I couldn’t zoom in and out. I could pan. I tried opening and closing the model. I tried saving the model to a new name. I tried copying everything to a new file.

When I copy the model to a new file, I get a large rectangular box, bigger than my model should be, with a branch that run out to who knows where. I’m able to zoom/pan. The box has a blue highlight on it, and what looks like a black bitmap on the blue access that I don’t recognize. The second I do anything, the box disappears and I can’t zoom again.

Desperate for tips that might help recover the model.

Thanks in advance.

How about sharing the .skp file so we can see what you are looking at? I’m going to guess the file is too large to upload directly. If that’s correct, upload it to Drop Box and share the link.

Are you using the free web version of SketchUp as your profile indicates?

Try sharing the model as @DaveR said.
My guess is that you may have drawn a line to a far who-knows-where and brought your camera to an equally far who-knows-where because

the box with the blue highlight probably a component as you’ve copied the model into a new file for the latter mentioned. The camera part is because you’re still able to zoom/pan but probably unable to see the model.

All the above said is just me guessing so if anything is wrong, my excuse is that we don’t have your model.

shop model.skp (9.8 MB)

Here’s my model

You managed to get the camera a long way from the model. That image you brought in from Google Earth isn’t terribly useful. At least for me it shows as basically a large black rectangle.
shop model.skp (8.4 MB)

It wouldn’t hurt to purge unused stuff from your model once in awhile.
Screenshot - 2_26_2021 , 4_39_14 PM

Even worse, that giant Google Earth image is nested in side the Clear Vue Cyclone component. Evidently that dust collector really can gather in everything from around it :laughing:

1 Like

This all makes sense. I just imported the DC yesterday to plan some piping. Importing the models is so simple, but a voice in my head is always telling me I don’t know what I’m really getting. Lesson learned.

I don’t use the camera so not sure what I did to get so far out. To SU’s credit I’ve redrawn most of my model in less than an hour.

Thanks for the tips and advice.


When you drew that line, maybe some point later you changed

Above, I made a box then a line really far away.

Then, maybe you went to scenes and clicked one of the camera angles.
See my box? No, it’s too small.
Maybe that’s what’s happened.

You are always using the camera, though not explicitly. It is the viewpoint, look direction, scale, and projection that creates the view on your screen. The issue is that SketchUp manages the distance of the camera from your model automatically and sometimes disastrously moves it very far from the model contents. This happens most often when you zoom extents in parallel projection and there is model content that is either very large or very far from the rest.

Edit: in case it wasn’t clear, I’m not talking about the advanced camera tools - that’s a different kettle of fish.