Hardware Acceleration on newer Dell 7760

Trying a trial of “Sketchup Mark 2017” I have read the other threads and downloaded the latest drivers from nVidia as well as a full uninstall of those drivers, then tried Dells Support Assist recommendation. I also went into the 3d Manager and changed SU17 to nVidia, multiple reboots and nothing.
This is a brand new, fairly ‘top of the line’ Dell laptop so I am not sure how its not working.
Dell Precision 7760
nVidia RTX A4000
Intel i7
64GB Mem

Is this version of Sketchup too old for this laptop?

Thank you in advance,

Are you connecting an external monitor through a “dock”? If, you might try connecting it directly.

You beat me to it… Just tried this and yessir, exactly that… just disconnected the D3100 and direct connected and I’m in…
Disheartening. Anyone know of a good Dock to use? Monitors have both DP and HDMI so I can use probably most anything.

At work I have met many problems with these. Currently I am using a HP laptop with a HP Thunderbolt dock and after updating the dock firmware, computer firmware and all drivers even remotely connected with the setup (display driver, Thunderbolt software, network driver…) it works for now. Fingers crossed.

I don’t know why the manufacturers of “mobile workstations” don’t take this seriously. A typical use case for these computers is just engineering or architecture clients doing most of their work on external monitors, and just this is why they want a discrete graphic card.