Hard Key Dimensions

Hello, I’m working off a Dell laptop and recently downloaded the free trial of Sketchup2023 which includes the Pro version. For some reason, the software will not allow me to hard key dimensions & angles. I’ve watched several YouTube videos and the software will simply not allow me to hard-key dimensions. Any help is appreciated.


How exactly are you trying to key in the dimensions? Exactly what steps are you doing?

Please correct your forum profile. The 30-day trial of SketchUp Pro is not the “Free Plan”.

To help achieve your goals, some time spent at the SketchUp Campus and at the SketchUp - YouTube channel will be very worthwhile. Both sites are from the SketchUp team. On the YouTube channel, pay attention to the Square One Series and Level UP series. They cover the basics for each tool.

What do you mean by “hard key dimensions”?

Just “typing the size from the keyboard”? If you just mean that, and are trying (for example) to set the size of a rectangle, what separator are you using between the length and width measurements?

Look and see what it is if you just use the mouse to adjust the size. Use the same character yourself when typing the sizes - a comma in most English speaking countries or a semicolon in most others. The character to use is determined by the computer’s regional and language settings.

And, very important, don’t click in the Dimension Window. Just type the required value.

For example, to draw a line of, say, 45 meters or 45 feet or whatever the units that you are using, follow these steps:

1 - Select the Line Tool.

2 - Observe what the message in the Status Bar (SB), below the modelling window is telling you. Click to start the line. A click is a press then a release of the Left Mouse Button (LMB).

3 - Move the cursor in the intended direction. You can lock on any axis if you want using the arrow keys. The SB is telling you to click to set the final endpoint of the line.

4 - Click again to finish the line or let go of the mouse and type the required length. In this example, type 45.

5 - Press the Enter or Return key to tell SketchUp that you have finished entering a value.

Done, you shall have a line.

1 Like

Thanks for your response.

When I click “lines,” I notice that there is a “length” box on the bottom right hand side. I simply click lines, then pull my first dimension and then click the length box and nothing occurs. I also make my first click with lines and immediately try to type in the dimension that I want and that doesn’t work. Lastly, I’ve tried to click the “Tab” but after my first click after lines and nothing allows me to insert a dimension that I’m needing. Any help would be appreciated!

Jean, you are a rockstar! You solved my problem here, thanks so much!!

That’s your problem. As @jean_lemire_1 wrote in the first line of his post, don’t click in the Measurements window. There is never a time when you should click in that window. Just type the dimension.