Grids in match photo do not appear


I am doing “Match Photo” but I can’t see grids in my drawing window.

Also, I have ticked Grid in Match Photo editor but it still didn’t appear.

Any clue?

The grid shows up only when you set the photomatch.

You can toggle between the Grid/Draw Mode as you wish by using the ‘Edit Matched Photo’ options, available as…

  • A Button within the Matched Photo window (click on gear/cog icon).
  • As a standard menu item >Camera >Edit Matched Photo.
  • or, via the Context Menu when right clicking on the photo itself, or it’s name in the scene tab row.

I’m assuming that you’re not seeing the grid because you’re not in the edit mode. If you are in the edit mode and it still doesn’t appear then the problem gets more serious — though given the lack of previous reports with this as an issue, I’d be pretty surprised to see it go in that direction.


The grids don’t appear when I am in “Edit Matched Photo”.


Be sure then when in ‘Edit Matched Photo’, that ‘Grid > On’ is checked (not ‘Grid > Auto’).
Also, if spacing is too small, the grid wont show. See spacing in the same window ‘Edit Mached Photo’.


I have done all suggestions but the grids still don’t appear.

Can you share the file including the mached photo?

See attachmenttest.skp (253.1 KB)

Check the scale of your image. I measure it as almost 300 million mm across.

a setting of 10,000,000 mm for the spacing of the match photo grid brings up the grid again — as do other huge numbers.

I think the best thing is to try and fix this at the image level – bringing it down to a more realistic scale.

I haven’t used matched photo in a while, and I can’t recall if we were able to scale the photo in previous versions or not.

In testing this with other photos on my computer, I have also imported some images which have a high scale factor.

That didn’t seem to be a problem before in previous SU versions.

I wonder if @Rimutaka may have stumbled upon a new problem here ??? (…or at least new to me).

Was this issue ever solved @Rimutaka?

This is currently happening to me.

Been using photomatch for years… all of sudden there is no grid. I’ve tried Spacing values from as low as Sketchup will accept to as high as it will accept and every power of 10 in between. Grid never shows up. Without the grid, you can’t set scale on the model (as far as I know).

This has happened on the last two models I’ve worked on, different photos, same result. The first time, I didn’t have time to fuss with it so I just modeled everything in the gigantic scale SketchUp stuck me with. That is not an option this time.

Well, I didn’t have time to really get to the bottom of this as I have work due on Monday…

so I uninstalled everything with AppZapper, then went hunting for the pref files in Application Support that AppZapper always misses. Fresh install and it works just fine.