Grey screen model disappeared

I’m new on Sketchup. When i tried to move something suddenly my model disappeared i dont know what happened. I have tried zoom extend and it doesn’t work. I’m sharing the model pls help me.
AutoSave_FİNAL ARAZİSİZ MODEL 17.06.2021.skp (5.2 MB)

I am trying to fix your file, but one question I have is whether you are using the web version, and downloaded the file to show us as a SketchUp 2017 file. Or are you using the desktop version of SketchUp 2017?

I think the “Autosave” in the file title suggests make 17. Eh?

Yes, good idea. His profile says SketchUp for Schools, which is only web.

Curiosity got the best of me and I took a look at your model. Tried copy and paste into a new file like DaveR tried. I didn’t get any bug splats but things would be moving along well and then would copy paste a group and it would throw the camera somewhere into outer space. After some trial and error was able to copy paste one of the groups causing problems into a new file by itself. I measured down one side of the group ( I believe it’s a line of doors running down the red and green axis ) . Was able to measure down one side of the group. The tape said 1515842141098.9233 meters !!! I suspect this insanely long group has something to do with the camera going crazy… Really curious if Colin is able to do anything with the model to save it. Suspect it might be a start fresh deal…

Sorry i’m using different computer so the version is also different from the profile. Right now I’m using desktop version SketchUp 2017.

I suspect it too something about measure. When i looked up for the problem people mostly saying about the extremly huge measure some of the groups cause problem. But i don’ know how can i find the wrong one and solve it the problem.

That is what I had been looking for, having seen a similar issue in another file recently. The way I do it is to export to Collada, then look at the XML. The massively wrong numbers are easy to spot. There were several of them, and I edited them to be a more sensible number. But, there must be more that I didn’t yet find.

Still trying other ideas.


The lack of any coherent naming convention for the various groups makes it extremely difficult to pinpoint the exact problem. Also the depth of the nesting of groups and components isn’t helping with finding what is triggering the camera to fly into outer space. I have found groups containing a component named
“CGM_Doors_SingleDoorFrame#7” causes the camera problem when copy pasted into a new model. But there are others I haven’t been able to pinpoint…