Ghosted images when exporting to a PDF


#1

Hello, I’m a longtime user but this is actually my first post here. Great community here. I’m wondering if anyone has had this issue as it just started affecting me today.

I have a multi-page PDF that I’m trying to export out of Layout. Once the file is exported some of the images appear to be “ghosted” out for lack of a better term. It’s not consistent when it happens and it doesn’t always happen to the same image. I tried re-building the layout file from scratch, made sure that section views were deleted as to not be randomly turning on and even built a new sketchup model thinking that there might’ve been some sort of bug in the model when it was imported into Layout. I even re-installed Sketchup and Layout. Nothing helped.

This is all done on a new MBP running 10.13.4 with the 3.1 ghz i7 + 16gb ram + Radeon Pro 560 graphics. I noticed that Apple just released an OS patch on Friday and I haven’t put together a presentation since then. I’ve done several presentations up to this point without issue.

This got me wondering if it’s something with the latest OS update?

I have an older Mid 2012 MBP with a 2.6ghz i7 + 8gb of ram + Nvidia GeForce GT 650M that is running 10.13.3 so I decided to install sketchup and layout on this machine and see what happens when I try to export the same file and everything comes out clean. The files exported from this machine look great.

Again, I’m just wondering if anyone else is having this issue. I’m also wondering if it’s Apple’s new OS update causing the issue or ? I get the same result if I export the file as a Pdf or if I use Apple’s “save as PDF” from their print menu. Any thoughts on this would be appreciated as I have no idea what else I could be missing…

Thanks!


Layout Washed Out when printing and print preview
#2

open the the “SketchUp Model” panel and try if changing the render mode to “Raster” or “Hybrid” helps.


#3

Thanks for the reply. I’ve been using raster for years without issue but I’ll give that a shot. I just need the textures to render and vector doesn’t allow this & hybrid mode takes too long to render each view when you make a change…


#4

Try resizing the viewport a bit and see if that has any impact.


#5

I just tested a new completely different file on both an older iMac and my old MacBook Pro that are both running 10.13.3 and the file exported to PDF just fine. On the newer machine running 10.13.4 it didn’t work. Completely random on which part of the file the ghosting effects each time. This is leading me to believe it’s a bug with the latest Mac OS software update.

Again, the newer MacBook Pro was exporting things just fine before this latest OS update that came on Friday. That’s what’s leading me to think it’s the cause…

I guess I contact Sketchup directly?


#6

Hi @Ideations - have you had any luck with solving this?

It first happened to me last week with a whole document (4 or so pages) - I usually ‘Print’ the document and then ‘Save as PDF’…however when the whole document ‘ghosted’, I tried to Export it as a PDF and it solved the problem.

Today however, I am trying it with a larger document (9 pages) and with both methods, it’s ‘ghosting’ only the first page. Working to a deadline, so am panicking a little bit!

I did ask a colleague to try it on her computer (she hasn’t done the new update - I told her to hold off!) and it too ‘ghosted’ the pages of the first document I tried.

Let me know if you’ve got any tips!


#7

Hey Ashleestark - Sorry you are having this issue. It’s been a complete pain in the ass. There is another thread started on this topic now as well. When I print some scenes lose color?

This happened to me right after the latest OS upgrade. I’ve been working with the Sketchup team for a couple of weeks now and we don’t have a solution that’s worked for me. My only work around has been to transfer the file to an older iMac with the previous OS installed and output to PDF from there. It’s been successful every time.

I wish I had a better solution for you. It’s been insanely busy at work and I’ve had to create presentations using Layout almost every day so it’s really cramped my workflow… I hope we can all find a solid fix soon…


#8

Hey @ashleestark, are you sure your colleague was having the same issue but she wasn’t on 10.13.4? Can you confirm with a screenshot, please? If she clicks on the Apple icon, and About My Mac, it would show the OS version. This would be super helpful for our QA team.
Can you confirm that you sent her your Layout file, she tried File > Print, and it gave the “Pastel PDF” effect?


#9

Hi @Katya, thanks for the reply! I just confirmed with my colleague and she is actually on 10.13.4.
I never sent her the document in question, we are connected to the same Dropbox folder, so she just accessed it that way. But yes, she tried File > Print and it gave the effect.


#10

I keep wondering if Apple may have changed or tweaked the way the OS handles PDF export in the latest release and that’s what’s giving us this error? Just a thought… I guess if that’s the case everyone would be having this issue though…


#11

Thanks, @Ideations - apologies, I didn’t see your reply earlier! Thanks for the link to the other thread - I’ll keep my eye on that one. It’s definitely slowing down my workload as well…exporting as a PDF seems to be working for some docs (just had success with one now when Print > Save as PDF didn’t work), but I’ll keep pushing on as much as I can!


#12

@ashleestark Do you have Adobe Creative Cloud installed? Or Adobe Acrobat? If so, what version?
Also, would you mind sending me a list of any other graphics-related Applications you have installed? Only if you want to. A private message in the Forums would work, or you can also create a help ticket at https://help.sketchup.com/en/contact and ask for me, if you’d like.


#13

Good news! We discovered that by removing the Color Profile from the PDF, it resets it and the PDF image looks normal again. Now we need to figure out how the pastel, odd Color Profile is getting attached to some of the PDF images. It seems to be a “calibrated” color profile.

Would anyone mind posting an image of your color profile window? It’s in System Preferences > Display > Color
It looks like this:


#14

How do you remove the color profile from the PDF?


#15

I’ll forward this forum link to our engineer so that he can post his workaround here when he’s back next week. I tested the workaround (with constant coaching from him), and it worked, but there’s got to be an easier way - it was not easy. I heard that with Adobe Acrobat DC, there might be an easier way, so hopefully we’ll figure that out soon. Well, more hopefully we’ll find a way to prevent this from happening in the first place, and figure out what it is about the OS x 10.13.4 update that is causing the weird color profile situation in the first place.
But the fact that removing the color profile worked at least gives our investigation a solid direction.


#16

The problem is that a color profile somehow assigned to some images in the pdf. The reason how that happens is unclear at the moment. But there is a tool called Ghostscript can be used to remove the color profile from images in a pdf file, thus, ‘fix’ the pdf after export from LayOut.

Unfortunately, there’s no user friendly installer, you have build it from the source. These are the steps:

  1. Download the Ghostscript Source (Ghostscript AGPL Release) here.
  2. Expend the downloaded file ghostscript-9.23.tar.gz, you get a folder “ghostscript-9.23”.
  3. Launch the Terminal.app, and issue these commands (assume the ghostscript-9.23 is in your Download folder).
    cd ~/Downloads/ghostscript-9.23
    ./configure
    make
    It may ask you to download build tool, just click OK. It will take few minutes to build. When it finishes, you should see the tool is created in ~/Downloads/ghostscript-9.23/bin/gs. Keep the file gs, you can trash all the rest.
  4. Download and unzip gs_fix_pdf.zip (3.8 KB). It’s a folder named “gs_fix_pdf” with a handy script “gs_fix_pdf.command” in it.
  5. Place the tool gs in the folder.

To use the tool, just place pdfs that need fix in this folder, double click the gs_fix_pdf.command to run the script. It will find pdfs in the same folder and fix them.


#17

Just thought I’d bump this back up to the top. I just installed the latest 10.13.5 update which I had hoped would somehow correct this issue but it still persists. I can’t wait for this to be fixed. I appreciate the “Ghostscript” work around that was provided but that isn’t something I should have to do with a product I purchased. I’ll keep my old iMac loaded with the old OS until something works itself out…


#18

Ghostscript option did not work for me. I simply could not proceed further than Step 3. As for workaround the only way I could get good quality images is exporting it to PNG with high resolution. PDF export works ok only if Output Resolution is set to Medium, but quality is not good at all. So Only way is PNG for now.


#19

Is there an update to this? The exports are useless washed out, and it’s been 5 months now since this was first reported. People earn their living through Sketchup and Layout.

I’ve just come across this when exporting files. If I open an old file and export, everything is ok. Sometimes I can make a few changes, and everything is still ok. But once it starts exporting washed out, it won’t go back to exporting normally.

If I close the Layout file (and don’t save), then reopen the file, it will export normally again. Until I reach a certain amount of time working in the document, when the exports will become “washed out”.

At present, I can’t quite pinpoint what command specifically triggers the images to become washed out.

Something interesting though is that when it happens, not all the pages within the drawing have the same problem. For me, it’s affecting my floor plans and elevations, but the 3D visuals I have are still exporting absolutely fine.

Whether this means the issue is a corrupted “style” within Sketchup, or whether it’s triggered by the orthographic view - I’m not sure.

Hopefully this is of some help in pinpointing the problem and fixing it!


#20

No update - it’s been completely quiet as if no-one cares that this is happening. 6 months later and I still have the same issues. I have one older Mac sitting here that I haven’t upgraded anything on and successfully use that one to export all of my drawings to a PDF format. Not a work around for anyone but me unfortunately. I’ve made my living off of sketchup since 2007 / 08 so this has been extremely frustrating for me…