Ghost images appear after import or copy and paste and I can't select them to delete

Several times after importing a model or copying a model, I paste it and then immediately or after moving it, a ghost appears that is either the overall shape of the model or just a flat dark rectangle which will be over to the side and maybe not even aligned the same. I am unable to select it and cannot delete without deleting the model and starting over. I have an 2009 mac mini and cannot upgrade anything on it. I don’t know if it is because the file has gotten too large and the processor is not up to par or what… I read the topic on Twilight but I don’t even know what that is… I am not using that.

I don’t see an icon for uploading a picture of my problem…

I found the upload button :), now for the picture: notice that there is a highlighted door on the basement level. I just imported that door and put it in place and suddenly 3 images appeared. Two dark ones one either side of the front door and a white frame image perpendicular to the large window.

Where did you get the door from? Can you upload that component?


We can only guess by looking at a picture of the model.
Sharing the model file will help us help you.

Post the model if possible. My first guess is that the door component you imported has inside additional things left there by accident.


Hollow Metal Door 3’x7’.skp (210.3 KB)

this is the door I imported, I selected the whole thing and created a component because when I clicked on it, only parts were selected. Then I copied and pasted it into my file.

Nothing suspicious in the door. How about your own model: for instance, is it very far away from the model origin point?
If you save your file and reopen it, are the “ghosts” still there?
If you go to Window menu>Preferences>OpenGL, uncheck “Hardware acceleration” and restart SketchUp, are the “ghosts” still there? If they are gone, you might try updating your graphics card driver.


@Miriam[quote=“Geo, post:4, topic:28078”]
Sharing the model file will help us help you.

Share the model file that exhibits the problem.
That is, the entire model depicted in the image you posted.

Hollow Metal Door 3’x7’.skp (210.3 KB)

The door does not seem to be a component so I selected the whole thing and designated it as such, then pasted it into my model.

I had already deleted the door and the ghosts went away. I just tried again to paste it as a group instead of component and there were no ghosts… then I deleted it and made it a component and the ghosts appeared! so, am I doing something wrong to make the whole door a component?

Also, I have old mac mini 2009, my son just checked to see if I could get a better graphics card and cannot upgrade, however, is that the same as updating the driver you suggested?

House with North front door.skp (2.5 MB)

I am trying to model a house we are building and adding on to, trying out different porch situations. I originally modeled it according to actual location so the axis are difficult to deal with. When I started to try out all sorts of treatment options, I kept using what I had already made to save time. However, new rectangles were hard to align on these surfaces so I tried to move everything to be lined up with the default axis settings… I am sorry, I am extremely new to this wonderful program and have learned from a multitude of errors. so, there are probably all sorts of no-nos going on here… lol

Hi @Miriam,

I’m not able to duplicate the ghost phenomenon, albeit I have a hunch about what may have caused it.

After working with the model it’s clear you’ve run amok of SketchUp layer system.
It’s likely the “ghosts” were the result of that in combination with having shadows turned on.

See this Help article and be sure not to miss the video at the bottom of it.
Controlling Visibility with Layers — SketchUp Help

Turning off shadows and all other unnecessary rendering effects will make the model perform much better.
See these articles:
Speeding Up Rendering with Fast Styles — SketchUp Help
Improving Performance — SketchUp Help

Thanks so much Geo, I will look at those articles and videos soon I hope. However, I have a new grandson and am off today to take care of the family. :smiley:

1 Like