Getting Started 4: Components video. Offset not working

I have just been running through a few of the getting started videos. I ran into a problem with offsets on the “Getting Started 4: Components” video.
At the point in the video where the instructor does the offset, I’m lost. I do the exact steps, but the offset tool itself shows a “disabled” or “unavailable” sign (like ghost busters) when I attempt to use it.
The video shows you editing the leg of the play place when it is a component.
I can draw another rectangle and get the offset to work, but not with a component as demonstrated by the video. Any ideas?

This would imply to me that you haven’t opened the component for editing first. Or the surface you are trying to use it on is more than one face.

If you share the SketchUp model, we can take a look and give you an answer without guessing.

Ok… I’m not sure how to share the model in Sketchup Web… Having said that, I did figure out the problem. The video indicates that the double click on the component will cause it to jump into component edit mode, but it does not. Once you suggested that it isn’t in edit mode, I realized the problem.
I did the right click and selected “Edit Component” from the context menu and it worked!

Thanks for your help!

PS - If you have any tips on how I can share the model, let me know.

1 Like

If you have the Select tool, double clicking on the component will open it to edit mode.

As for sharing the model, download it to your computer under the file folder icon towards the upper left. Then upload the file here. Alternatively you can share the model to the 3D Warehouse and provide a link to it here.

When I have the selection tool selected, and the mouse cursor is a normal arrow, and I double click, I get the outline of the component. Then, if I select the offset tool and hover over the component it only gives me the little red circle with the slash through it, indicating I cannot do this.
If I right click the popup, it has the “Edit Component” option. If I select that option, it will now work.

Getting Started 4 Component video off set problem.

You have the Pillar component wrapped in a group. I suspect you made the group and then opened the group for editing, selected all of the geometry and made a component. This results in the geometry being double wrapped. So to get in to access the geometry you need to double click twice. Once to open the group and again to open the component. Your double clicking and then right clicking to select Edit Component does the same thing.

The extra wrapping isn’t useful and has really only served to get in your way this time. I would select each of the groups and explode them leaving the pillar components.

Wow Dave… You is on the ball…

I had in fact, accidentally created a group first and was unaware how to delete the group. Then I made the component as I was directed.

Ok, so that explains why it happened!


Good deal.

For the future, if you inadvertently make a group instead of a component you can right click on it and choose Make Component. To avoid making a group in the first place, one easy thing would be to use the keyboard shortcut G which will open the Create Component panel.