GeoLocation Makes View Blank?


#1

Hi, I have a .skp model that I want to line up with a map on Google Earth. When I grab the screenshot of the area I want using the geolocation tool, it appears that my model completely disappears, and I can’t even see the section of google earth that I was trying to import in my model view. I’ve tried zooming around and moving the screen, but I can’t see anything. My layers still seem to be in tact. Anyone have useful help?


#2

Maybe you can upload an example model?


#3

How can I do that? I have a screenshot of the before and after adding the geolocation here:


#4

The .skp is 14.4mb after purging, so Google won’t let me upload it :\


#5

Can you replace your geometry with a simple one and purge the model? Or will this change the error?


#6

I’m not really sure what you mean by “with a simple one”; I’m sorry, I’m definitely a noob to sketchup; I’m on an IT team trying to get a 3D model provided by a Civil Engineering team up onto a website that we’re building for them, but Sketchup seems to hate the .dwgs provided by them. It took a lot of research and exploding in AutoCAD from a fellow teammate to get a file that would even import in the first place, but luckily we can at least import and see the model now.

EDIT

Did you just mean to remove the model entirely and draw a few lines in its place to see if I can still see that after aligning a map?


#7

Yes, something like this.

Did the import of the DWG changed the origin of the model?


#8

I’m wondering if it affected the origin as well, but should the Axes tool fix that? I put the model in a top view and aligned the axes to the model before using the geolocation tool.

EDIT

Is there a way to erase geometry from Layer0? If I’m in layer0, select all, and delete, it seems to erase everything from my other layers (at least, I have a blank view)


#9

You could try to upload your model using a cloud service (eg.Dropbox, Google Drive, or iDrive for example.)


#10

Are you really geolocating? And why do you need Earth? Clicking the icon 4th from the right and entering an address to get the ground plane from Google (enter an address, set grab rectangle). OK, now you have your model in your location with ground image and terrain.

Upload that model to 3dwarehouse (50 MB limit). Click on “View in Web GL Viewer”. Get the embed code on that page and put it in your web page and you have a nice, interactive 3d view. People with downlevel browsers will still get our swivel view (a set of images for a poor-man’s Web GL view).

You could also export this as KMZ, let people download it and run in their own version of Earth.

Lots of options here. Try them out for what meets your needs best.


#11

That fourth icon from the right is exactly what I’ve been trying to use- mouse-over says it’s a geolocating tool. Once I grab the capture, there is no map or model anymore, as shown in my screenshot.

I just need a way to have an interactive 3D model with a map lined up behind it so that I can create clickable points on certain locations to have a box show more detailed information, and I would ideally like it hosted on the website’s server; is this possible with sketchup?

I’ve just been taking this one step at a time, but I was hoping I’d somehow be able to get an embeddable google earth view of it that I was hoping could be accomplished with a KMZ.


#12

Was the checkbox “Preserve Drawing Origin” activated for the import?

Are the different layers added while adding the geo location? Did you try the zoom extents button?


#13

His screenshots show that the second model has a geolocation in it.


#14

Layers only control the visibility of the geometry. If you group some geometry, assign that group to another layer to control its visibility, the geometry in that groups stays on layer0.


#15

https://drive.google.com/file/d/0B5P6sQe2JIO7RTFuZHlOQ2tHUG8/view?usp=sharing

Here’s the .skp if someone doesn’t mind taking a look- thank you so much for your input guys, I really appreciate it. I’ve tried the ‘zoom extent’ button, but it doesn’t seem to do anything after the geolocation.

Right now we’re just working with a very small section of the model as a dummy file because the full model DWG provided to us was 97Mb unfortunately and sketchup fails to import, but that’s an issue for another day xP


#16

You’ve turned on the fog (window->fog->checkbox), maybe this is the reason for your “disappearing” model.


#17

Nope :, the fog doesn’t seem to affect anything. I can see everything with fog checked before the geolocation anyways, but even unchecking it and then doing the geolocation doesn’t help. The axes are just on the right side of the screen like in my screen shot and zoom extents does nothing to the view windows.


#18

More than 240.000 entities for such a small model, you should try to find a way to reduce this, otherwise you will never have fun with that model in SU…


#19

Yeah, unfortunately my team knows nothing about 3D modeling since we’re just IT majors. I guess we’ll have to end up telling ourproject sponsor that this isn’t possible unless the civil engineers provide a model with simple geometry and not so many entities, but they keep telling us it’s impossible to shrink a ~100mb model down to a few mbs. Very frustrating haha.

Do you have suggestions for what we’d need in an autocad model that would import and work well with sketchup, so I can try and articulate this to our engineers? I’ve opened up the autocad file before and there are hundreds of layers and entities and my '14 Macbook Pro can’t even handle moving the view around without lagging and freezing.


#20

I just put the ‘Tape Tool’ on your model and it seems to be in ‘mm’ for items that appear to need to be ‘cm’…
as well as being 13573454mm away from origin…
the fog also makes it disappear to easily, and a simple ‘fast’ style would help…
I’ll look further if I get some time…
it seems to be very badly made…
john