Placing models in Google Earth


#1

I’ve read that you can’t place models students make in Sketchup 8 into real maps in Google Earth. First of all, is this true? If so, how do you do it in the newest Sketchup? This would entail a lot of downloading of the new version, so I’d prefer to avoid that if I can and keep working in Sketchup 8. Thanks!


#2

You can still view your models in Google Earth as before, but Google has stopped including hobbyist’s 3D models into its “official” 3D layer, so viewing has become a private activity. This is the same for all SketchUp versions.

Anssi


#3

Like @Anssi said, you can’t load your models into the public Google Earth anymore. But you can download Google Earth and load your model to see it on your computer.
To do this:
Export your model as a .KMZ format, open up Google Earth and import (or drag and drop) your kmz model. Note that you should geo-locate your model in SketchUp so that it’ll load in the proper place in the world.


#4

Ok. How do you “geo-locate”? And how come my model seems to be floating? Is there a way to adjust placement once in Google Earth? Not being in Sketchup means I don’t have access to the tools, right?

Also, I don’t care about public sharing. I just want the kids to be able to place their models in a real map. Can they take a picture and how high-res will it look?


#5

To Geo-Locate: File->Geo-Location->Add Location.

If you’re model seems to be floating, then it’s not at the right height on the Z-Axis. And yes, within Google Earth, you don’t have access to SketchUp Tools. if you need to make changes, you’ll have to do it in SketchUp and re-export to KMZ and re-import into Google Earth.

As for an example of all this: They can export images from Google Earth and it can look quite nice, depending on the area. Some places in the world have great 3d buildings (like New York City), while others have much choppier images.


#6

No Geo under File. Any chance you could include a screenshot?


#7


#8

Under File mine starts with Open, not New. And Open wants to open a file on my laptop. I don’t have all these options.

I see something about an account and signing in. Do I need to do that?


#9

no you don’t need to sign in.

which sketchup version are you using? I checked as far back as su8, it’s the same.


#10

Sorry, thought you meant in GE, not in S/U. So when I do that in S/U it takes me to a window to sign in to my Google account. I don’t want that.


#11

Also, I’ve downloaded Google Earth on some laptops and I’m getting this message upon opening: “Google earth failed connect to database”. What is that?


#12

So when I go to grab the location it doesn’t drop it into my s/u file automatically. When I drag the kmz file into GE it ends up in some weird place on the map. Then it’s also out of scale. What am I missing? Anyone have a link to a good tutorial on youtube for all of this? Thanks!


#13

Please help. I am really stuck!


#14

Upload a kmz/SU file and I’ll take a look.
If it’s in the wrong location, I’d assume the geolocation coordinates are wrong.
For scale issue, are you drawing to scale or just visually?
And I don’t know why when you grab location it doesn’t load into SU automatically.


#15

Every model has a Location, even when the model is not Geo-Located.
You say you’re using SU 8
The default location in SketchUp 8 is:
USA
Boulder (CO)
40.017000N
105.283000W

The default location in SketchUp 2015 is:
USA
Boulder (CO)
40.018309N
105.242139W


#16

What do you mean “take a look”?


#17

Hi @teacher,

Anybody reading a thread in this forum can view the items you upload. This is what @quantj was referring to in his statement.

It’s easy to do it if you don’t already understand. Just click on the upload arrow at the top of the response box, find the file you wish to share with us and dbl click that to transmit.

Send the file in and one (or more) of the folks reading this can probably offer some insight to help address the issue.


#18

Here’s what I’m seeing:

  1. After I make a model in SU I geo-locate. It tells me I have to zoom in before it can find it. Then I manually zoom in and find the location. I get the pins and then grab the mapped area. Then I have it but nothing happens. I just have an image from the map in a separate window.
  2. With a kmz file when I drag and drop in GE, it sends the model to some random location.
  3. When I grab the area of the map, it’s supposed to come right into my SU file. It doesn’t. So…

What is the order of actions I am supposed to take between the two programs?

Thanks again.


#19

Why not send in the kmz and/or skp files to allow others an attempt at re-creating your issue. It will be easier for one of us to suggest a feasible approach if the problem is clearly recognizable.


#20

Shot in the dark, what is your layers showing after the grab?