GeoLocation Makes View Blank?

You should request your engineers to execute a purge command on the autocad file before transmitting it to you. Engineering firms often do not employ standards for reducing the file size of electronic documents. By the time a drawing is ready to be sent to a client or a consultant, there may be numerous blocks, linetypes, layers, text styles, dimension styles, etc. that are no longer in use. Removal of these items can make an acad file significantly smaller. Once the cad file is transformed into a SketchUp document, it may be further reduced in size by removal and/or consolidation of selected layers and by using the Purge Unused button in the Model Info box found under SketchUp’s Window>Model Info>Statistics dialogue menu.

I offer no guarantee, however, I have used this technique to minimize size of cad files before converting to SU files with some success.

The problem is as @john_drivenupthewall describes.
The model Import Units were set way too small and the model is located some 14km from the Origin
As it is in the file you shared, the bridge measures a mere 60cm in width.

Look under the Options button when you import the CAD file.
• Try the exact settings shown below.
• You can always scale the model down in size if the Meters setting is too large.

Then, go to the Layers Manager … Window > Layers
• Delete all Layers thereby assigning all geometry back to the Default Layer 0

As you have concluded the model you received should have cleaned up before even given to you. Usually the bloated model size is caused by over zealous use of photo textures and model size reduction in this case is relative easy , but unfortunately your case is geometry related and getting significant reduction becomes a major issue. For example I reduced duplicate vertices by 136,489; null faces by 87; 827 vertices merged and deleted a number of non-manifold and self intersecting faces . After quadratic edge collapse decimation by 1/2 the model size only went to 11.1 MB. During the above ops some faces were lost and some re-meshing will be required. I also moved model close to origin.
For what its worth I’ll attached and try some more later.

A 2.7 MB version for what it is worth. Problem with trying to correct , the clean up steps are sequence dependent and some times the model get destroyed but still lots of dirty geo that would require fixing.bridge_mac1_0308B_1117.skp (2.7 MB)

I have verified I see the same problem under following conditions:

  1. Down loaded your model ( ;
  2. Changed units ref per George’s input above;
  3. moved model the 14+km to origin;
  4. Use Boulder Colorado ref as geo-lcation. For SU 8 and SU2015 I can get the map showing but when grabbing the location model disappears. There is a few seconds of pause before that happens.
  1. However if I then clear the geo-location the model re-appears. Various combinations of using fast feed back, max texture size and OpenGL results in same result. I also opened Goole Earth and deleted all places and deselected all layers and got same result. In the failed condition zooming +++ in the model is there but very small, snap shot and terrainis there but very blurred.
  2. Doing the same with the smaller model I cleaned some I can geo locate OK. :rage:
    I have guess on what problem is but will require more work.

I made a carnial error of trouble shooting < making more than one change at time. Deleted Google Earth and reloaded and IE also plus making some option changes then lost signature above, but did find he problem with “blank” is the view setting namely the fog and shaded with textures +you should make the other changes noted above also.
If I was going to use the model re-drawing would be about as quick as correcting. Good Luck.