GeoLocation Grab Crashes / Freezes SketchUp2017


#1

Ever since upgrading to SketchUp Pro 2017 I am no longer able to grab a screen shot using GeoLocation–> Add Location. It just freezes the program, there is no bug splat or crash. The blue spinning circle shows that the computer is busy and it just stays there.

I have tried:

  • to uninstall and reinstall
  • verified it’s pointing to the correct video card
  • click around to force a bug splat
  • let it sit overnight, thinking maybe it just takes longer to load

Nothing seems to work. I went back to SketchUp Pro 2016 and no issues are experienced.

Any tips, tricks or suggestions? If not, I will continue to use 2016 until this is repaired.


#2

How large is the area are you trying to grab?


#3

I have tried both, a zoomed in area (About 2 blocks) all the way up to a country. I was hoping to find a sweet spot, but nothing took; same results each time.


#4

You can’t grab a country. Google restricts the camera height, and you’d be too high to see a country… even Lichtenstein. I just tried. No Lichtenstein.

And here’s a portion of Lichtenstein from Win7, SketchUp 2017:


#5

An update while testing…
I can create a .skp in SketchUp Pro 2016, grab the desired location save, then reopen in SketchUp Pro 2017. It will then open with no complications. I can then add imagery and continue without any crashing.

So it seems the issue is the initial grab!


#6

Typo on my part, I meant county.


#7

Wow… that’s a new one. Thanks for reporting back on that, and glad you can make it work. We’ll try to see if we can reproduce this in some way.


#8

I have the same problem. I hoped today’s update would have solved the problem, but no.

Sometimes I can avoid hanging by tilting to a birds-eye view before importing aerial image, but not always.


#9

The same thing is happening to me. It is super frustrating.


#10

Any help in reproducing this? All geo locations? All sizes of captures? Different z levels? Can you import images in SketchUp?


#11

I have tried multiple locations without success.

I have reinstalled SketchUp 2017 with no success.

I have tried various sizes (block-house scale)

I click grab, the window minimizes, I open the window and it is a blank white w the toolbar and trays visible.

The cpu usage of sketchup remains almost constant after is freezes, but memory usage seems to keep climbing to no end (it is now at 4,000 mb) at a rate of about 8 mb/s.

I have used a colleagues seemingly identical setup which works to do what I needed.

I don’t know.


#12

Very weird. Can you do File->Import and import an image? Can you do Camera->Match New Photo?


#13

File->Import does work as well as Camera->Match New Photo


#14

SketchUp Pro or Make?

When you installed it, did you right click on the installer and use Run as administrator?


#15

It is SketchUp Pro. No I did not use ‘Run as administrator’.

What would that change?


#16

You should indicate that in your profile.

Edit, I see you’ve updated your profile. Thanks.

Then SketchUp is not installed correctly. It must be installed using Run as administrator from the Context menu when right clicking on the installer for proper installation.

As to whether or not it’ll affect the specific issue, I can’t say. But SketchUp does need to be correctly installed.


#17

Installing with ‘Run as administrator’ did not resolve the issue. Do you think it could be a hardware incompatibility issue of some weird sort?


#18

It could be several things. Hardware incompatibility could be a possibility.


#19

Yea, but you can import images through other means. Geo-location imports an image and data, and you can do that… so I’m confused. We ship Chromium for Add Location in 2017, so if you can open 3DWarehouse, Extension Warehouse and things that would use Chromium and they’re OK, then that’s likely not it. Confused.


#20

Same here trying to import area near Philadelphia airport. Memory on task manager is way high. Not responding. I have been using 2017 since it came out and this problem is new to me. That said Geo Location is a key tool I use and I am very disappointed in the new imagery. Hard to go backwards with a tool that has worked great for 15+ years and now just has fuzzy bad imagery.