Geo-locate not working


Trying to use Geo-location and I get and error returned as follows.

However I am logged in. Any suggestions why geo-locate won’t work?

I did note a Windows 10 update today. Any link?

EDIT - Just in case anyone else has Windows 10 related issues. I had problems printing on all printers and eventually I had to uninstall both the Net framework updates that I received yesterday. Then printing worked. Forgot to test SU again but will do so a bit later.

Did to you try logging out and then back in?

I would recommend signing out, restarting then try signing back in. @Devine let us know if that helps.

I have had a couple of other reports about this, and just got off a screen share with one such case. It was with a Mac user, which meant I couldn’t look at the developer tools to check for errors on the initial opening of that window, so I went ahead with the next test.

Instead of signing out, quitting, opening, signing in, I had him close the add location window, sign out, then open the add location window again. That triggered the sign in, he signed in, and then saw the add location intro slideshow for the first time. From then on the features worked ok.

After importing one site I had him quit SketchUp and open it again, so therefore still signed in. Opening add location worked fine. It seems like on the first use of add location it misreads whether you are signed in or not, but after it knows you are, things are good.

Aside from wanting to test with a Windows user, to look for the initial error, next chance I get I will have them try what Dave and Bryce were saying, sign out, sign in, then try add location. The difference is whether it was add location that initiated the sign in, and that may make a difference.

Hopefully we won’t get enough reports of this problem for me to be able to build up statistics! But, I’m ready with more things to try next time.

1 Like

Follow up note, the using add location window to trigger the sign in isn’t something you can do in SketchUp 2018. There the only option is to do a regular sign out and sign in, and it does fix the issue (I was able to reproduce the problem in 2018).

1 Like

Thank you Colin

I’m on SU Pro 2019, so I’ll try your first suggestion and report back.


This did the trick. Thank you so much.

Your profile indicates 2018. Please update that since knowing the version is often important in helping you solve your problems.

Thanks for bringing that to my attention. Can’t remember having entered that info in that first place. Will edit, when I get back to the office.