Generate Report not recognizing grouped items?

I generate a bill of materials several times a day for my clients. Today as i go to generate a report the reporting system is not recognising any component that is in a group… After several hours trying to chase the problem (including a full uninstall, a subsequent test using SketchUp 2021 ((same result)) I’m at my witts end and further snowed under. Can anybody who uses Reports on a regular basis please test thier system and tell me whether grouped items still show up?
It’s not a nesting level problem as report is set to ‘All’


works for me, can PM the sketchup file and can check

We get the same problem, we use the report to generate our BOM, and now we are not able to get the info about components on 3 levels. It seems the report can only search on 2 Level, and it’s a big problem for our workflow. We make climbing walls, and we have a component(1) for the frame, inside this component we have all the components(2) of this frame, and each component can also be made of components(3). We can get the report to give us anything according to components(3).
It seems there was an update between 4:00PM GMT the 10/01 and 1:00PM GMT the 11/01, because yesterday I was able to do the exact same thing without any problem (same file, same way to do this). We tested it on different computer and different files, it’s the same for everyone in my company.

We have the same issue here and that’s a really big deal too… I don’t understand what’s going on, this is a “small big” creating a huge problem.

as a workaround – it seems like the high-level group is being ignored (as groups are) – maybe create a copy of the project called " - QUOTE" and then explode the group(s) to expose the components?

That’s a quick fix, very risky however. I also have a projet with over 18.000 items. That’s not a clean workflow.

Yes this is a nuisance. We often generate reports, and now there will be additional steps to ensure we have the same results.

We also have the same problem and we have tried several options of explode and new drawings but nothing helps. Hopefully there will be an answer soon!!!

Yes. Exploding looks like a good way to deal with the problem. In small, and some medium projects. Big projects would need lots of micromanagement.

Why have they changed this? My whole operation runs on thousands of nested components within components! I can no longer operate this way. It would take us weeks to explode our projects down.

This needs rectifying back to the way it was?! Hopefully this is a bug?

1 Like

Hopefully yes. Makes no sense to me to change that. Especially when nothing in the release notes mentions anything related to reports and grouping options

I don’t use Generate Report but I can guess that it uses a web interface of some sort. They haven’t changed something, you would need to download and install a new version for that to happen.
My simple guess would be that since a bunch of people have suddenly had a problem is that something has gone wrong on one of their servers.
Reporting it here means that it will be seen and addressed if it hasn’t already been.

Same problem here. there are five of us in our group and we’re all having the same problem.

Same problem here. I hope this is a glitch. My entire workflow revolves around reports.

A forum search reveals it has gone down before.

I submitted a ticket to Sketchup, and they got back to me fairly quickly with the response pasted below. Hopefully they are able to restore the previous functionality quickly. Cheers to all, and I’ll post back when I get any updates.

Hello Lance,

Thanks for reaching out to SketchUp Support!

I am not aware of any changes to the Generate Report function, but based on your ticket and the Forum Post you supplied, I am going to escalate this to our Tier 2 Team and have them take a look.

The SketchUp Support Team at Trimble Inc.


You can reply directly to this email directly to continue this discussion. If you need help with something else, please fill out a new ticket here. We appreciate your help in keeping our ticketing system in order!

Want to model on the go? Check out the new SketchUp for iPad!

Original Message:

The generate report functionality changed yesterday, and no longer is including grouped components in the resulting reports. This is causing an enormous disruption in our workflow, because we use the reports to create take-offs many times every day.

I thought we had perhaps changed something inadvertently, but I found on the user forum that this change is being seen by many other companies using this feature like we do. Here is a link to that discussion/post. Generate Report not recognizing grouped items?

PLEASE restore the settings back to the way they were before yesterday.

thanks Lance, I hope it is sorted today as this has crippled my business!

a couple of tests: whether a group or component, the report does not show internal components UNLESS i switch the report to “Current Selection”. it will show all the components inside - but only that first level. If I open the group or component and select all the internal components, then i run the report and can see the top level inside those.
so, depending on how deep you need to go, if it’s only the first level, or opening the group/component and selecting all, then you get the next level, perhaps that can be a workaround until a fix is found.

as a note: i actually never use generate report as it has always been buggy. since most of my work involves construction i use OpenCL (OCL) and while it has some things that have to be configured to make it work as expected, in most case even parts and things of that nature are reported nicely.

My entire team is unable to generate reports when a component is nested more than 2 times… I am using SketchUp Pro 22.0.354 and another team member is on 22.0.316 and all started having this problem late yesterday 01/10/2023. Exploding the higher level groups is not an option for us… We can’t risk and accidental save over the original.

Throwing my hat in here for visibility’s sake.
My office is having the same problems: Report entire model gets just parent level, report selection gets levels one and two. One of our guys found something saying the report function is web based so it can be updated independent from the application’s update cycle. If that’s true I guess it would explain why reporting changed across different versions?

1 Like