Generate Report (cvs download)

When I download a report from the Generate, why is it not putting the information into columns?

CSV is a comma-separated values i.e. the comma is used as a field separator. As you can see in your image, the comma is also used as a decimal separator. I am familiar with this situation, because in my country the comma is also a decimal separator, but the field separator is a semicolon.
Therefore, Excel does not perceive a comma as a field delimiter and does not split CSV file rows in columns.

Try next:

  1. open a blank Excel worksheet (definitely first, because Excel corrupts the content of the clipboard when you open it;
  2. generate a SU report;
  3. select all report cells content, including header and copy it (Ctrl + C);
  4. go to Excel worksheet;
  5. paste the copied content.

Thank you for the explination. I’ll play around with this. I do wish that I can do something to go around any copy past that I need to do.


It’s not as complicated as it sounds! :grinning:

If you manage to find a more rational way, I will be happy to learn it from you.

I use Libre Office Calc (on Windows) but, generally, it is very similar to Excel.
Generate your report in Sketchup.
Hit the ‘Download’ option and save the report to a convenient location. It will be a CSV file.
From the saved location open the CSV with your spreadsheet app.
You should then see an opening panel with various choices on how your data will be set out. In Libre Office, for instance, there is a button to select ‘Fixed Width’. All your data will be in just one column.
The other option I have is ‘Separated by’. Here I can choose which characters are used as delimiters thus separating the data into separate columns. Hit ‘OK’ and you should see your data suitably arranged. If not just start over and check or uncheck delimiter options. Save as an Excel file type if desired. No cut & paste needed!

I was going to rant about the same thing. My result out of trying to export DC attributes was even more garbled.
The formatting in the example has several errors: for instance, there is no double quote before the first separating comma.

In this example, it won’t work, because here the comma is both a decimal and a field separator. That is the crux of the problem.

By the way, it is interesting why the values in the first column (LenX) are not defined as text, i. they are not enclosed in quotation marks.

Try having a look at the language settings in your Spreadsheet app. It might be that the solution lies there. That’s as much as I can suggest.

In excel, from data tab, import CSV, change the delimiter to custom then type “,”

1 Like

Thanks, @pcmoor, for reminding me of this opportunity! In the old versions of Excel, I dropped it because I couldn’t find a code page to display accented characters correctly. There are no more problems with it in the latest version.

By the way, in the @davidwetzel80 example a Comma as a delimiter fits as well.

Thank you everyone for the input. I had success with pcmoor example however (for the results I’m looking for) I went back to using the plugin SU2XL from Wisext. No formatting I required, and it can update the model or the Excel worksheet both ways.

Thanks again guys, your attention and quick replies were greatly appreciated! :blush: