GeForce RTX 2060 Nvidia Settings

After having so many recent issues with my ASUS i7 gaming laptop GTX 1070 (mostly with windows 10 updates and now hardware issue and will be sending it back to them for repair), I purchased a new Dell desktop XPS 8930, 32GB DDR4 2666MHz (4x8GB), 1 TB PCle x4 SSD + 2TB HD, Nvidia GeForce RTX 2060 6GB GDDR6, CFL-R i9-9900K 8-Core (FY19HOL) Could someone please tell me what the optimal Nvidia 3d settings should be configured to and do I change the global settings or config to the specific SU program settings or both. Using latest version SU 2019 and iRenderNXT. Your advice is very much appreciated. Barb

Right click on the desktop>Nvidia control panel>Manage 3D settings>Global settings>Open GL rendering GPU>select the 2060>under Power management mode > prefer maximum performance. apply settings.
Under program settings Select Trimbal SU Open GL rendering GPU select the 2060, apply settings.

thank you so very much for responding so quickly…have a wonderful day. B

ALSO wandering if the following - under program settings should be also changed to (read that someplace):

Anisotropic filtering be: Application-controlled
Antialiasing - FXAA: On
Antialiasing - Gamma correction - On
Antialiasing - Mode: Application-controlled
Open GL rendering GPU: GeForce RTX 2060
Texture filtering - Anisotropic sample: Off
Texture filtering - Negative LOD bias: Allow

I leave those settings at the defaults.

thanks… B

Need your help again: I just updated my SketchUp Pro 2019 licence to the latest update and somehow I lost my Nividia Control Panel when I right click to check the settings.

I got the following message when I downloaded the update:

  • SketchUp has detected your computer system has multiple graphics cards and is defaulting to an integrated Intel graphics card. SketchUp will perform better if you change your system to default to the AMD/NVIDIA card.

See this Help Center article for more information.

How do I fix this please???

Barb

The Nvidia Control panel should be found in the context menu when you right-click on your Windows desktop background. If it doesn’t appear even after restarting your computer, I would try updating the Nvidia driver (download and install from the Nvidia website). This fixed it for me ( a different model graphics card, though).

thanks will try that - I just loaded the N updater to see if it will pick it up …B

I don’t see much use in having Windows switch back and forth between the integrated and the dedicated GPUs.

So on my machine I set nVidia Control Panel “Global Settings” to use the “High-Performance NVIDIA processor”

Please stay out of the BIOS settings unless you are a trained IT tech or have many years experience configuring computer hardware.

It is preferable (and easier) to use the nVidia Control Panel as shown above.

After being unable to download a new Nividia control panel (but I was able to updated the driver) I contacted Dell support but they weren’t able to repair remotely and deemed that the video card had failed. Since it is under warrantee and only a month old, they are sending a technician out to repair it and change the video card. The technician first told me they were going to replace the motherboard but called me back later and said its only the video card that needs replacing. Now can’t help but wander if the RTX 2060 is reliable. Have just contacted them again to see if they should upgrade if the 2060 in fact has issues and am willing to pay the difference. Will see what they come back with on Monday. So disappointed - hard to get reliable pc’s or laptops these days. Cheers, B

1 Like

Dan: totally agree - am not comfortable in going into the bios settings… will wait for the dell technician to replace the video card… thank you for all your advice.

Power saving? (if running on battery)

I’m always plugged in, and I cannot see running a high-end dedicated GPU for heavy work (like rendering) when only on battery.

I agree with @DanRathbun: you should never run a renderer when on battery as it will very likely drain the battery before the render completes. That risks losing work. And even SketchUp will cause a noticeable decrease in runtime when on battery. It’s just the nature of the GPU.

Nope …

I wasn’t even rendering anything. This all happened after I updated SU 2019 to the new release. It gave me that message and then I wasn’t able to even find/open the Nvidia control panel (right click on screen) - was working perfectly prior to the update. Rendering was so much faster then my ASUS i7 1070 laptop. Driver was updated and couldn’t install the new control panel so that I could switch back to Nvidia instead of using the Intel graphics setting panel. The Dell technician couldn’t fix after trying different things to reinstall the Nvidia control panel - hence they first thought it was the motherboard itself but later called me back to let me know it is the video card. They are sending a technical to install the new
RTX 2060 graphics card for my new Dell XPS 8930 i9 desktop in 3 working days since it is under warranty. Its all so bizarre. Maybe I just got a ‘lemon’ graphic card but starting to think that maybe there are issues with the card model. It did sound unusually loud for me but was told its normal for desktop.

Will ask the technician for the 3d Nvidia settings for SketchUp when he is here - in case there is something different to change with this graphic card for rendering…

Thank you all for trying to help…Barb

Has anyone have had issues with the Nvidia RTX 2060 graphic card? Just wandering if I should upgrade to the 2070 instead since Dell is going to replace. B