"GDSII Importer" Plugin problem


#1

Hello there,
I trying to import GDS files to SketchUp 2015 using the GDSII importer plugin.
I tried the example the author included in his package here:
http://www-lab13.kuee.kyoto-u.ac.jp/~tsuchiya/gsu/index_en.html
and it works fine.

However, when I try any other GDS file, it doesn’t work…I even tried opening his example in a gds editor like Calibre/Klayout and saving it as another file (with .gds extension of course) and then tried to import it into SketchUp…but that didn’t work as well. I also tried the same with SU14 but with no success.

So maybe the problem lies within the gds file editor when saving the file in a different format . So I viewed the gds file with gdsinspector to spot the differences between the original gds example file and the one I saved as a in a different name…There were some differences actually like the GDSII version used (v5 for the original and v600 for the resaved one), but not sure if that is the root cause of the problem.

I looked up the ruby console in SU15 to check what the error message is…It says:
Exception NoMethodError' at C:/Program Files/SketchUp/SketchUp 2015/Tools/GDSII_importer.rb:950 - undefined methodelements’ for nil:NilClass
Error: #<NoMethodError: undefined method elements' for nil:NilClass> C:/Program Files/SketchUp/SketchUp 2015/Tools/GDSII_importer.rb:950:inbox_stream’
C:/Program Files/SketchUp/SketchUp 2015/Tools/GDSII_importer.rb:817:in convert_gds' C:/Program Files/SketchUp/SketchUp 2015/Tools/GDSII_importer.rb:164:indialog_create_box’
C:/Program Files/SketchUp/SketchUp 2015/Tools/GDSII_importer.rb:170:in block in <top (required)>' SketchUp:1:incall’

Now since I am not a ruby expert, I can’t tell what do I need to change in the code to work properly.

Any ideas?

Thanks in advance!


#2

@ahmad2080,
you have it in the wrong place, which could be causing issues…

form your link…
Unpack the GDSII_impoter-0.x.zip and copy GDSII_importer.rb and GDSII_importer folder into Plugins folder of SketchUp
john


#3

Thanks John,

I changed the path to the Plugin folder but still the problem is there…The original example is working fine but any other gds file does not work at all!

Ahmad