Extension problems with sketchup 2024

I just updated to sketchup 2024 (and yes, I updated my profile here also :wink:), and certain extensions don’t work anymore, they are shape loader, artisan (artisan 1), clothworks, flextools component browser, and 3darc studio. I get an error message (in the new extension error window) that “error: NoMethodError (undefined method ‘exists’ for file:class)”. does anyone know how to fix this?
@Yoni @Whaat

Did you copy the extensions from your previous installation? Many extensions need updating with fresh versions.

All the extensions are newly installed

The method File.exists? has long been deprecated, but worked.
In the latest Ruby version it doesn’t - File.exist? - works in v2024 and older versions as well.
Developers are working to adjust their code accordingly.

Have patience and post any instances here as there are 100s of 1000s of line of code with the tiniest corrections needing to be found and change, then the extension re-encrypted and signed…

Many authors have already fixed their extensions, so look to see if there’s already an update available…


the exact errors are

Extension Errors Report
SketchUp: 24.0.484
OS: Windows 11
Ruby: 3.2.2

Extension: Artisan (1.3.7)
Error: NoMethodError (undefined method exists?' for File:Class) c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/dm_artisan/artisan.rbe:38:in load_c_extensions’
c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/dm_artisan/artisan.rbe:1013:in <module:Licensing>' c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/dm_artisan/artisan.rbe:205:in module:Artisan
c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/dm_artisan/artisan.rbe:2:in <main>' c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/dm_artisan/artisan_load.rbe:37:in eval’
c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/dm_artisan/artisan_load.rbe:37:in require' c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/dm_artisan/artisan_load.rbe:37:in block in load_source_files’
c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/dm_artisan/artisan_load.rbe:37:in each' c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/dm_artisan/artisan_load.rbe:37:in load_source_files’
c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/dm_artisan/artisan_load.rbe:40:in <module:Artisan>' c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/dm_artisan/artisan_load.rbe:4:in module:DM
c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/dm_artisan/artisan_load.rbe:3:in <main>' C:/Program Files/SketchUp/SketchUp 2024/Tools/extensions.rb:197:in eval’
C:/Program Files/SketchUp/SketchUp 2024/Tools/extensions.rb:197:in require' C:/Program Files/SketchUp/SketchUp 2024/Tools/extensions.rb:197:in load’
C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/DM_artisan.rb:35:in register_extension' C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/DM_artisan.rb:35:in module:Artisan
C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/DM_artisan.rb:8:in <module:DM>' C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/DM_artisan.rb:7:in <top (required)>’

Extension: ClothWorks (1.7.7a)
Error: NoMethodError (undefined method exists?' for File:Class) c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/ams_clothworks/extension_manager.rbe:71:in block in require_all’
c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/ams_clothworks/extension_manager.rbe:69:in each' c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/ams_clothworks/extension_manager.rbe:69:in require_all’
c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/ams_clothworks/main.rbe:746:in <main>' C:/Program Files/SketchUp/SketchUp 2024/Tools/extensions.rb:197:in eval’
C:/Program Files/SketchUp/SketchUp 2024/Tools/extensions.rb:197:in require' C:/Program Files/SketchUp/SketchUp 2024/Tools/extensions.rb:197:in load’
C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/ams_ClothWorks.rb:38:in register_extension' C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/ams_ClothWorks.rb:38:in module:ClothWorks
C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/ams_ClothWorks.rb:7:in <module:AMS>' C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/ams_ClothWorks.rb:6:in <top (required)>’

Extension: FlexTools (2.12.0)
Error: NoMethodError (undefined method exists?' for Dir:Class) c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/f3d_flextools/main.rbe:70:in module:FlexTools
c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/f3d_flextools/main.rbe:19:in <module:F3d>' c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/f3d_flextools/main.rbe:18:in
C:/Program Files/SketchUp/SketchUp 2024/Tools/extensions.rb:197:in eval' C:/Program Files/SketchUp/SketchUp 2024/Tools/extensions.rb:197:in require’
C:/Program Files/SketchUp/SketchUp 2024/Tools/extensions.rb:197:in load' C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/f3d_flextools.rb:17:in register_extension’
C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/f3d_flextools.rb:17:in <module:FlexTools>' C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/f3d_flextools.rb:7:in module:F3d
C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/f3d_flextools.rb:6:in `<top (required)>’

Extension: Shape loader (1.4.0)
Error: NoMethodError (undefined method exists?' for File:Class) C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/isna_ShapeLoader/extension.noc.rb:13:in module:ShapeLoader
C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/isna_ShapeLoader/extension.noc.rb:3:in <module:IsNa>' C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/isna_ShapeLoader/extension.noc.rb:2:in <top (required)>’
C:/Program Files/SketchUp/SketchUp 2024/Tools/extensions.rb:197:in require' C:/Program Files/SketchUp/SketchUp 2024/Tools/extensions.rb:197:in load’
C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/isna_ShapeLoader.rb:30:in register_extension' C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/isna_ShapeLoader.rb:30:in module:ShapeLoader
C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/isna_ShapeLoader.rb:10:in <module:IsNa>' C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/isna_ShapeLoader.rb:8:in <top (required)>’

Extension: 3DArcStudio 3D Tree Maker (1.10.11)
Error: NoMethodError (undefined method exists?' for File:Class) c:/users/tenen/appdata/roaming/sketchup/sketchup 2024/sketchup/plugins/3darcstudiotree/3darcstudiotreemain.rbs:4918:in f3das_addsubmenus’
C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/3darcstudiotree/3darcstudiotreeloader.rb:16:in <module:M3darcstudioextensions>' C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/3darcstudiotree/3darcstudiotreeloader.rb:6:in <top (required)>’
C:/Program Files/SketchUp/SketchUp 2024/Tools/extensions.rb:197:in require' C:/Program Files/SketchUp/SketchUp 2024/Tools/extensions.rb:197:in load’
C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/3darcstudiotree.rb:17:in register_extension' C:/Users/tenen/AppData/Roaming/SketchUp/SketchUp 2024/SketchUp/Plugins/3darcstudiotree.rb:17:in <top (required)>’

See TIG’s post.

You must scroll all the way down and save the changes you made in your profile information.

You state that one of the extensions that is not working for you is Artisan 1.

But the latest version that appears to be compatible with SketchUp 2024 is Artisan 2

Sorry, Artisan v1 is no longer supported and not compatible with SU2024


Edit: I have added the error code that was apearing also by 3darcstudio to the earlier post with the other error codes from the other extensions.

The same issue TIG referred in his reply nearly 20 minutes ago.

Some extensions will probably tae a little while to get updates from the authors if they are still maintaining them. You should contact the authors directly.

last update is from 2017.
unless 3darcstudio decides to come around and fix everything, you might be stuck with this one.

On my end, I’ll probably keep a SU23 installed for some time, just in case I need an obsolete extension.


Is there any hope of it being updated for this?
(I don’t use artisan enough warrant getting a yearly subscription, especially since I am not using it for any work really as of now.)

1 Like

another porblem I am having, the icons of certain extensions (for example 1001 bit tools) seem to have gotten bigger. I remember there was something similar in 2023, but in 2023.1, it is fine, but now in 2024, it is back, and even worse.
here are screenshots of 2023.1 and 2024
Screenshot 2024-04-04 201609

I know it is old, but it was still working in 2023. Weirdly, the first time I install it, it works, although the toolbar doesn’t show up, but if I close sketchup and restart it, I then get the error. The other extensions don’t load at all.

I don’t think the icon problem is with the extention, I think it is with how sketchup is displaying it, like I mentioned that I had a similar problem in 2023, but in 2023.1 it was solved.

The crack hasn’t been released yet.

1 Like

As a quick workaround, this issue could probably be fixed by writing a custom extension that just makes Ruby aliases for the missing methods. It’s a hack that someone already needed for some other Ruby things. The first thing to try would be copy-pasting the content of that file (the lines after the require_relative) in the Ruby console of Sketchup. I bet that makes many of the broken extensions work again.

(update: I tried with the VR Sketch extension and it seems to fix that particular problem; but then it crashes with a different error because of something else that was removed by the Ruby upgrade of Sketchup. I expect many extensions to have similar troubles. In the case of VR Sketch, see here for the potential fix.)

I’m unable to install Lumion Live Sync in 2024. Anyone else having this issue? I can only find it on the extension warehouse.
Screenshot 2024-04-05 085841

Most of my plugins installed great.
Some notable ones that worked : Medeeks, many Fredo’s, Tigs, GKware cabmaker, Many Thom Thoms (TTlib), Profile builder 3, many Eneroths, Curic Scale++

SUPodium needed a beta version (didnt see a non beta) but it works for the podium browser.

My 5 failures are:
Clothworks - (likely abandoned but worked in 23)(i would love to see this render in the new engine)
D5 render/livesync - No 24 version available yet
Unreal datasmith - no 24 version available yet
Artisan 1 - Dale no longer supporting into 24.
Toolbar Editor - (I just installed this last week on 23. Hoping it will be updated for 24)