Problems with GDSII Importer Plugin


#1

Hi all. I’m a new user to SketchUp 14 after having it recommended by several friends and have been impressed by the tool and the support community. My goal is to take a 2D GDSII file from Cadence Virtuoso and create a 3D shape using the appropriate technology file. I tried using the GDSII Importer Plugin at http://www.tamaru.kuee.kyoto-u.ac.jp/~tsuchiya/gsu/index_en.html. Based on the sample files included with the program it does exactly what I need. However, I always receive the following error at startup.

Error Loading File GDSII_importer.rb
Error: #<LoadError: cannot load such file – /gdsii/byte_order.rb>
C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in require' C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:inrequire’
C:/Users/mrcol_000/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/GDSII_importer/ruby-gdsii/lib/gdsii.rb:108:in <top (required)>' C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:inrequire’
C:/Program Files (x86)/SketchUp/SketchUp 2014/Tools/RubyStdLib/rubygems/core_ext/kernel_require.rb:45:in require' C:/Users/mrcol_000/AppData/Roaming/SketchUp/SketchUp 2014/SketchUp/Plugins/GDSII_importer.rb:44:in<top (required)>’

I’m on a Windows 8.1 machine if that helps. I appreciate any help or suggestions you may be able to offer.

Best,

Dave


#2

SU14 changed the location for 3rd-party plugins. The plugin is looking for stuff in SU’s Tools directory. Plugins should not be putting anything there in SU14.

It would be best to to contact the developer to update the plugin for the new standards introduced in SU14 http://help.sketchup.com/en/article/38583. Also SU14 updated Ruby from 1.8 to 2.0. That may be an issue too.


#3

Moving this over to the Extensions Category to keep things accurate.


#4

I am the author of the plugin.
As mentioned, the cause is the version of ruby.
Since ruby 1.9, the rule of LOAD_PATH was changed. So the plugin cannot find the files in ruby-gdsii library. I added the LOAD_PATH by the following code.

$:.unshift(File.dirname(File.expand_path(__FILE__)) + '/GDSII_importer/ruby-gdsii/lib')

I released the fixed version of plugin.
Thanks.


#5

Thanks Akira for fixing the plugin. And thanks for the great tool.
Best,
Dave


#6

Thanks Akira. Just tried it and it works!
Best,
Dave