Frozen model won't allow new objects?

Hi,
I’ve gone back to a model file from a few years ago, and I don’t seem to be able to add any new objects to it. So creating a line object, I click on start and drag out a line but when I click on the end, the line disappears and I’m left with only a connection point and that disappears when I click off the object. I’ve tried dragging to select the object (assuming it’s just hidden) but there’s nothing there. Can’t create any object type including guide lines.

I’ve also tried to change Style, but that removes 3/4 of the objects in the model.

Context:
Model created in a free downloadable version of Sketchup (sorry, not sure what version but about 2015).
Now using SketchupWeb on Win10
Model has opened using Training Style but if I create a new model now it opens with Architectural Style and works just fine.
I can edit existing objects in model, just can’t create or view new ones. (yes, I could copy existing objects but it’s a bit of a pain).

Am I missing something obvious?
Simon.

Share the .skp file so we can see what you are working with.

Sorry, here’s the old file from my PC. I have the same result whether I open this one or save it online.

Woodcliffe Hall Plan6.skp (318.7 KB)

I had a suspicion that it was going to be incorrect tag usage. You have Untagged visibility turned off so things you add that are untagged won’t show.

Screenshot - 1_17_2022 , 9_41_14 AM

Try this file.
Woodcliffe Hall Plan6.skp (195.1 KB)

Going forward leave Untagged (used to be called ‘Layer 0’) active. The pencil icon should always be set to Untagged. ALL edges and faces should be created and remain untagged. only groups and components get tagged. Here I’ve fixed the incorrect tag usage.
Screenshot - 1_17_2022 , 9_42_52 AM

I also purged unused stuff from the file which reduced the file size by nearly 40%.

See if this file behaves for you.
Woodcliffe Hall Plan6.skp (195.1 KB)

Hi Dave,
Thanks so much for the swift reply. A few issues remain:

  1. On SketchUpWeb, I don’t see the Untagged category in my list so I can’t toggle visibility for these objects:
    image

Also, is there a way on my version to automatically assign new objects to a layer. (You’ve resolved in this model but I have others which will have the same issue and I don’t want to have to post up here to get them fixed !).

  1. I gather that Tag has replaced the Layers I was familiar with when a more regular Sketcher. I used them in the model to enable me to hide/reveal groups of objects e.g. in the model I can hide the left wall and roof to see the interior.
    Is this a sensible procedure or would you suggest something else?

  2. I don’t really need to use Styles, but is there any reason much of the model disappears when I click an alternative - and stays invisible when I return to Default style.
    (not essential but asking for completeness in case anyone else needs to know).

Cheers,
S.

Don’t do that! It’s possible but VERY highly recommended NOT to assign any tag or layer other than Untagged or in older versions of SU Layer0 to any ‘raw geometry (edges and faces).

Assign any other layer or tag only to groups or components, or to non-geometric objects like text, dimensions, or section planes.

And ALWAYS leave the default layer or tag at Layer0 or Untagged (with very rare exceptions when you really understand what you are doing and why).

It’s exactly what they are for.

Probably because one or more of your Styles (including the Default one) has the Untagged tag turned off.

Styles are helpful in combination with Scenes to save different views of your model in (potentially) different styles - for example, an X-ray view - or in Monochrome rather than Shaded with Textures.

See learn.sketchup.com.

Right. Untagged was removed from the Tags list to prevent users from doing what you did in that model on the desktop version. Unfortunately that means for old models like yours in which tags were used incorrectly, the way to fix it requires deleting the existing tags.

No. Your best bet in SketchUp Free would be to delete the existing tags and then create new ones to give to the objects (components and groups) in your model. Alternatively you could use SketchUp 2017 Make and correct the tag usage without deleting all the tags. SketchUp 2017 Make is still available and free for your hobbyist use.

Yes. Tags replaced Layers. And yes, they are used for controlling the visibility of groups and components. In the model you shared there’s a lot of loose ungrouped geometry that was tagged. You need to be using groups and components for that stuff.

FWIW, this thing of keep geometry untagged is not new. It’s been the “rule” for at least as long as I’ve been using SketchUp starting in 2003.

It depends on the style. Styles do not have any impact on tag visibility but it’s possible that some things might seem to disappear if the style is set up to not show it. For example changing to Hidden Line style would not display colors and textures.