Untagged missing, pencil to select active tag is missing

I’m using Sketchup Free. It seems that the Tagging menu is changed. Due to this changed there are problem I’m facing since yesterday:

  1. the Untagged tag is disappeared from the list. The only way to see entities assigned to Untagged tag is to turn visible all tags. I tried to sarch for untagged, also for layer0, but there is no result.
  2. I can’t see the pencil icon at the end of the Tag row, so I can’t change active Tag to edit.

I tried to clear browser cache, also cleared service worker cache, logged out and logged in again. Nothing helped. Any idea?

image

If I try to change the tag assigned to a entity, then Untagged is listed there:

check this thread:

1 Like

Thanks! That explains almost everything!

I thing that’s still not solved yet: the artical says “To see all Untagged objects, you can simply turn off the visibility of all tags and folders using the new “Master Visibility” toggle.” My problem that it seems that the active tag stuck and basicly I cannot turn off to view it. That means I cannot turn off the visibility of all tags using the master toggle, and thus cannot display untagged only. And there are a couple of things untagged in my model by design. So there is no way to select them easily.

what happens if you reload the model?

This could be because you are editing a group or components that are assigned to the tag you want to hide. Actually your current editing context is inside of group or component.

1 Like

The untagged Tag is still available in the entity info panel

I think we will see a lot of this.
From what I see it is caused by having a tag other than untagged active prior to the change.
If you save a model on the desktop with tag 1 active and open it in web you get the same issue.

The removal of the pencil appears to be designed to stop people making a specific layer active (which is something we have been asking for for a long time) but it may have created this locked tag bug.

2 Likes

This is definitely a bug and definitely frustrating! It is locked to a single tag. I can not switch between tags/layers now. Why would the pencil be requested to be removed? This means I have to edit the tag of single line that is made in my sketch! Very frustrating

Thanks the info dezmo. I double checked: I’m at the outer context, nothing is selected, I’m not editing a grp or component, but that tag (which was the active when I saved the model with the previous Sketchup Free build) is always visible, cannot turn it off.
Any other idea guys?
It seems I’m not the only one facing this issue.

Oh, got it: here is the workaround:

  1. Create a new tag: “tag copy”
  2. Delete the stuck tag, in the dialog select the option: Assign another tag: “tag copy”
  3. Then all your entities will be re-assigned to “tag copy”, but your stuck tag will be deleted.
    After that you can reach untagged entites by toggling back and forth the master view.
    image
2 Likes

Hey everybody: thanks for catching this bug and detailing what is happening! We are definitely tracking the issue and thinking through the right strategy for a fix.

Thanks @DanielLoczi for sharing your workaround; in the short term, this looks like a good way to preserve existing tagged elements on the ‘ghost’ active tag while resetting to a place where all new geometry is created untagged. But we will dig in here; obviously, this will call cause the kind of confusion we are trying to minimize.

2 Likes

Perhaps set the current tag to ‘Untagged’ while opening?

1 Like

Yeah, that’s what we’re looking into! Just gathering the dev team here shortly to discuss.

A fix is in the works! We will keep you all posted on when it will be available.

2 Likes

Hi everyone, the fix is in! Thanks again for reporting (and for the clever workaround). However, this should now be fixed for everyone. The one small catch is if you load a model that previously had an active tag, it will require you to save the model the first time you open it since the active tag has now been switched to the untagged tag in the background. Please let us know if this fix is working on your end or if there are any other issues that pop up.

4 Likes

That would be the fastest bugfix in the history of SketchUp, can’t you guys fix some in the desktop version, too?:smiley:

5 Likes

I had this problem myself and spent a couple of hours trying to figure out what happened to the pencil icon and the untagged “layer” before I found this. I think I understand what has happened, but would really appreciate confirmation: So the pencil icon is no more and everything is now forced to be created untagged. But the untagged “layer” isn’t visible unless you click entity info. And, there is no way to create content in any tag. Once content is created as untagged, it can then be subsequently tagged. Do I have this right? Anything I missed? Thanks.

To the devs… first of all, great product! Secondly, I posted a separate thread about a different, but clearly related problem and @slbaumgartner linked me there (thank you!). The suggestions here did not solve my problem. And, in fact, when I followed the dev suggestion, it did nothing. And when I followed some of what I saw @DanielLoczi doing, it caused all the keyboard shortcuts to stop functioning! (crazy). Ie. pressing “spaebar” no longer got me the selector, pressing ‘h’ no longer got me the move-hand. I was scared, I cried for a bit…

Then, to resolve it, I selected one of my components, double clicked into edit it, messed with the various visible tags (semi-randomly). Then saw I was able to create elements again. After that, I exited the component edit mode and the whole thing seems fine.

So for now, I’m fine, but probably some issues still lingering for others.