From Sketchup go to procreate

Is it possible export 3D sketchup go (for I pad) files to procreate?

I think that Procreate can import USDZ files, and that iPad can export those kinds of files. Or it will be able to at some point.

Found it it is already released, but is due to have some fixes:

https://forums.sketchup.com/t/export-usdz-for-procreate-still-broken/196990

I have been moving the files via trimble to pro on the desktop and exporting as obj then downloading them into procreate.

And these obj files work nicely there? Without needing uv unwrapping?

I wouldn’t say nicely, no. They come in as one massive solid.

Bit when you paint one side/face of the object, does it paint on any other place of the object or just on that particular face?

It paints the whole thing. Definitely needs unwrapping.

You can unwrap in Blender, but that is one more extra step. A bit over the top.

This should work from SketchUp for iPar to procreate right out of the box.

1 Like

@marijusemail to answer your question, yes, it should be possible to go from SU to Procreate, via the option to export USDz from the SketchUp app. However, there’s a bug on the Procreate side. We’re reported the issue, but I can’t speak knowingly to the status on their side. My recommendation would be to file a bug report/feature request with the Procreate team. I think it would be more impactful for them to hear directly from all of you than it would be for me to remind them.

2 Likes

I just did that:

perfect. Thanks, Joao!

Ohhhh… That’s the name of some software. I clicked on this thread for the wrong reason I guess. :rofl:

@marijusemail @Danimaupin @JQL I got word that the latest update to Procreate includes a fix that now allows for going from SU to Procreate when exporting from SU via USDz. I’ll be curious to get your take on how that’s looking now.

2 Likes

I was able to export a simple model to procreate. Whohoo!

Of course the following issues happen with it:

From a post I made in alpha I think the following issues would be great to be addressed

Right now I am wondering what to do to fix the Uv issues and I think I will leverage the project markup to faces feature.

It would be great if we could export only a component from our model into procreate. Changes happening to the textures there word then be reloaded in our model

@MikeTadros I tried it twice. It crashed any time I tried to export it from inside the model via the scenes exporter, but worked great from the general file menu.

I did my Smurf house first (which I consider to be a well organized model) and it came in a little wopperjaw. Some bits here and there out of place. I wasn’t able to do much with it in procreate other than throw down general color and that was a little… off as well. The colors in the second image are what it exported from Sketchup. The third image was me trying to apply a pink color to one flower petal… just one, ha.



The second model I tried was the weathercock, and that is definitely not a well organized model. It came in better than the smurf house, but maybe that’s because a lot of it was one group (when it shouldn’t have been by SketchUp standards). The textures I had on that were a wood grain I had drawn and then used the color augmentation on in SketchUp when the material was uploaded. The color didn’t transfer, but the original woodgrain did. Applying color to this model worked a lot like the Smurf house, however, I expected it to, mostly because a lot of this is badly grouped. … … I was just a young’n back then. :stuck_out_tongue_winking_eye:



With both exports, I received the same warning screen as João above.

“I got a rock!” - Charlie Brown
IMG_2312
Guess I’m overdue to buy a new iPad.

1 Like

@Danimaupin and @JQL Thanks for the reports!
We’ll dig back into the questions about UVUnwrapping the models when exporting to USDz and see if there’s anything we can do on our end to further enhance. We also have a ticket on the board to fix the crash that happens when exporting from the Scenes panel.

@Danimaupin would you be willing to share the Smurf hut with me? I’d like to have one of the devs here take a look at why those parts aren’t showing up in the correct spot.

@RTCool Just got my M2 iPad Pro and I highly recommend! The performance is insane, and the new capability to hover with Apple Pencil is… well… how it should have always been!
(we’ve got a few kinks still to work out with Hover and iPadOS16, but I’m really excited about both the new OS updates and the new hardware)

I’m really looking at them. For years before you launched the iPad version, I’ve said the problem with SU on iOS is the inability to hover the cursor. I thought click-move-click was a brilliant solution, but now if you can hover, maybe you can get it all with Just Draw mode? That would be fabulous.

And now I find out just how it is not a well organized model.

Smurf house.skp (646.3 KB)

You do get it all, and it IS fabulous!

1 Like