Free sketchup web app not working right

HI everyone,
I’ve been using the free app.sketchup.com online since December 2018. Suddenly this week, when I download .skp files from the warehouse and go to the trimble connect to upload them and use them, they either give me an error saying they cannot be uploaded at all, or if I get them to upload, they don’t save. I frequently get the error “there was an error fetching this folder’s contents. please try again later.” this happened out of the blue. Can anyone help? thanks.

Got the same error, even moved my files to the European Server through Trimble Connect and they were back for a couple of minutes in Sketchup. Now I get the same error again and when opening through Trimble it says “Failed to locate the requested model”. But I can view the files with the Trimble 3D Viewer just fine.

This may have something to do with Trimble’s server network in Ohio which was impacted by tornadoes a couple of days ago. They have reported that they are working on getting things sorted out.

Edit: While I was typing that, a report came in indicating that things are looking up. Might be worth clearing your browser caches and trying again.

Ok, got it working by using incognito mode (which is basically no cache and no cookies), so there must be something off with the sessions and accounts, because it doesn’t work with the old cookies.
Solution for people having this issue and using chrome:

  1. Go to chrome://settings/siteData?search=cookies
  2. Under search cookies search for “sketchup” and “trimble”.
  3. For each result click on Remove All Shown