We’re having an issue reaching Trimble Connect

Using Sketchup Free (web) I can create a new folder, create a new model, but I cannot save the model. I repeatedly get:

ERROR
We’re having an issue reaching Trimble Connect. Please download a backup file. While you try that, we’ll be working on this issue.

I download the model to my HDD. When I try to upload it, it generates the same error message. I use the latest Google Chrome browser to access the web interface. I had the issue yesterday and it continues today.

Was this resolved? I’m getting the same error message for the last 4-6hours.

Here are all of the causes I’ve seen for this fairly catch-all message. Hopefully one of these will help you:

  1. Somebody’s date and time settings were off on their computer.
  2. Someone’s firewall, blocklisting, VPN or virus protection such as BitDefender is blocking the app.
  3. Somebody was referencing a shared model that had been deleted by the original owner in Trimble Connect. Test this by going to Trimble Connect to see if the file is still there.

#2 seems to be the most popular reason.

1 Like

Thank you. #2 it was. I disabled Bitdefender protection and immediately was able to save.

1 Like