Fredo Scale TAB jumps

Hi All!

I installed SU 2022, and I don’t know if this is a 2022 issue, but when I type in a dimension in the upper field and then use the TAB key to move on to the lower field, the cursor jumps back to the upper field. Never had this issue before! Does anyone has the same problem? thanks…
Screenshot 2022-01-30 155258

You might want to ask in the FredoScale thread on Sketchucation. Or even check the last few posts in the thread to see if it’s already been reported and fixed.

Did you copy an old version of FredoScale or did you install it fresh from Sketchucation? Is LibFredo6 up to date as well?

I updated all Fredo’s plugins to the most recent ones. :confused:

It is a long known issue that tabbing does not work correctly with the UI.inputbox of the API.
The normal workaround is to implement a web-based dialog instead.

Hi Dan, thanks, but it has always worked for me. It sudden doesn’t anymore.

As I wrote in my first reply, you should post in the FredoScale thread at Sketchucation.

There is a major bug, which seems specific to SU2022 (it does not happen in SU2021).

It is even worse than a problem of navigation by key. In SU2022, the standard Input Box has a bug and lets all keys go to the underlying tool (TAB and other keys).

Since TAB is used by FredoScale to popup the dimension dialog, a second TAB within the dimension dialog will create a second dialog box.

I’ll log the problem to the Sketchup team.


Hi Fredo, thanks for your reply. Wow, glad to hear it is a general bug. As your plugin(s) are ESSENTIAL in my workflow, I hope they can fix it soon. :pray:

Since it may take a while before the Sketchup team fixes the problem, I have published FredoScale v3.2a which implements a workaround to the bug in SU2022.

Note that you need to also upgrade to LibFredo6 v12.4 or above.


Thanks Fredo! Going to install it right away! :wink: :pray:

Problem solved Fredo! You rock! :heart:

1 Like