Fredo tools not working

I just purchased, activated, downloaded and installed JointPushPull, Curvizard, Curviloft, FredoCorner, FredoScale and a few others (purchased as a package). I updated LibFredo6 to the latest version, shut down and restarted SU (and then the computer).
None of the plug-ins are working–none of the toolbar buttons does anything.
Please help!

Better to ask at Sketchucation where you bought the extensions. Do you have the current version of the Sketchucation tool installed, as well? Did get the licenses and install them?

See this thread:

Thanks for the quick response, Dave.
Sketchucation says all my extensions are up to date, and lists sketchucation among my extensions.
Yes, got licenses and installed them.
I read through the thread you put up, but no insights.

What version of the Sketchucation tool are you running?

And post-install, all the menus appeared, and all the extensions say “enabled” in the extensions manager.

Have you quit SketchUp and restarted it?

Yes. And then, when that didn’t do it, restarted computer.

SketchUp was installed correctly? Right click on installer, Run as administrator?

BUT, just discovered:
the Fredo plug-ins work if I double-click the buttons!

That seems kind of odd. I don’t have to do that on my end.

Yeah, I had some of these in the past–just paid and re-installed–and it wasn’t that way.
I’ll take it…
Thanks for jumping right in (as you do).

1 Like

You have something corrupted in your OS. I had similar issues with SketchUp and one or two other programs. A format and fresh install cleared all issues.

Computer has been a bit quirky for a while.
Makes sense.

I have the same issue on 2023. It works fine on 2022 still, but in 2023 I have to double click the button to activate it.

This is not generally a good troubleshooting methodology. That’s a huge investment in time and effort (reinstallng an OS) when faced with issues in only one app.

I’m not having any issues with Fredo’s extensions on my PC with SU2023. Make sure you have installed SketchUp 2023 correctly which requires right clicking on the downloaded installer file and selecting Run as administrator. Do it now and choose the Repair option when it is presented. Then make sure you have the latest version of Fredo’s extension and LibFredo6 installed as well as the latest version of the Sketchucation ExtensionStore tool. Use the SCF ExtensionStore tool to install Fredo’s extensions. Then to make sure everything is loaded correctly quit and restart SketchUp.

1 Like

Hi, I reinstalled Sketchup 2023 without effect.

What did help was reinstalling the Sketchucation ExtensionStore tool. While the window showed 4.3.0 down below, the top window-label showed 4.0.0. I thought it was up-to-date by showing the original 4.0 and the point update at which it was currently running at, below. Obviously incorrect.

Once I installed the latest, both numbers match. I didn’t have to reinstall any of Fredo’s plugins. The single-click to activate a tool just worked immediately.
skethucation-plugin screenshot

[EDIT] For me this update of the Sketchucation tool to the latest version worked and is now ‘fixed’. I hope the sequence helps others who’ve got a hiccup.

How did you install the extensions when you first installed SketchUp 2023? Did you copy them from the earlier version?

I did with some other extensions, but I knew Fredo’s tools require proper installs and used the Sketchucation tool for those.

1 Like