Flummoxed by dimension

SketchUp Pro 2019 (version 19.1.173) running on iMac Mojave 10.14.4.

I created model and set the dimensions to use slash endpoints for leader lines and the dimensions “aligned to the dimension” and “above” the dimension lines. At some point I selected one particular dimension, changed the location to “outside” and then hit “update selected dimensions”. That worked fine.

I now have another dimension that I need to move the text “outside”. However, when I select that dimension, change the text location and hit “update selected dimensions”, nothing changes. I can change the leader line endpoint settings for either a single or all dimension lines and that works but I can no longer change the location of the dimension text for a single or all dimensions.

I’m flummoxed, what am I missing?

Is it possible that dimension is inside a group that isn’t opened for editing? If so, you need to select the dimension, not the group.

Nope. To be sure, I drew a separate line with a dimension, not part of any component or group, and I get the same thing, I cannot change the location of the text dimension. I also tried saving, closing SketchUp and then re-opening the file. Same thing (i.e. no “joy”).

Upload the SKP.

Okay, here tis
XXX site plan.skp (1.5 MB)

So this doesn’t work for you?

Or this?

Which specific dimension is causing you problems? I can modify all of them (unlike the screenshots @DaveR showed, I am also using 19.1.173 on macOS 10.14.4, but that only affects the cosmetics of the GUI).

I noticed a couple of things that may be related to your issue:

  • It appears you have manually edited most of the dimension texts, possibly to get decimal feet instead of the model’s Architectural units (feet and inches), perhaps to modify them to measured dimensions that the drawn model does not match, or perhaps to pad them with spaces to alter the placement of the text. Be aware that editing the dimensions’ text converts them to fixed text, breaking their value’s association with the underlying geometry. The text will no longer update if you move the underlying edges, won’t track model units, and may become incorrect. Several of them already disagree with the values you would get from the model! To convince yourself what I say is true, try this: open the 6850 lot component for edit and move one of its corners. You will see the dimension leaders follow the move, but the dimension texts won’t change! It’s possible that is also the cause of the issue you describe.

To my knowledge, there are only two ways to repair such dimensions (assuming you haven’t knowingly made them inconsistent with the model). You can delete them and redraw them. Or you can set the units to what you want (decimal feet instead of Architectural feet and inches) and then edit each dimension’s text to <>. That’s a “magic” value that tells SketchUp “put the real length here”. You can use it to mix real dimensions with annotation text.

  • You are not using SketchUp’s layers in the recommended way, which may eventually cause problems. You have numerous edges and faces (aka “primitives”) using other than Layer0. That does not isolate them or prevent them from intersecting or sticking to each other, which can cause confusing issues as you edit your model. You did use a component for the lot and a group for the house, which prevents them from interacting with the “loose” edges and faces making up the driveway, the road, and the various boundary types. I didn’t examine inside the group to see whether it has any issues with unintended intersections, though I did find that it has a lot of edges and faces associated with other than Layer0, which should not be necessary when groups are nested properly. But those loose roadway and boundary primitives do intersect each other. You can verify this by selecting them - you will get bits and pieces, not entire logical edges. This is the reason why the developers’ decision to implement dashed edges via layers was highly controversial and is strongly disliked by many of us. It would be better to gather each kind of dashed edge into its own group and then assign a layer with an appropriate dash pattern to the group. Doing so will cause all edges inside the group to take on that dash pattern while also isolating them from unintended interaction with other dashed or plain edges.
1 Like

Yeah, that works fine but what doesn’t work is selecting the dimension and then trying to change the text location (e.g. above, centered, outside) for either “select all dimensions” or “update selected dimensions”.

Yesterday I also tried using the Entity Info window but I couldn’t get the window to expand down to show Advanced Attributes. Today when I try, it works fine and now I can set the text location of the specific dimension. Go figure, cockpit error I assume.

But the questions till remains, why can’t I set the dimension text location for all or selected dimensions using the Model Info window?

I don’t know why it doesn’t work for you unless you are missing some step. As you could see in my previous GIF, selecting a dimension and modifying it works just fine here.

And here, selecting all dimensions and modifying them works fine, too.

Thanks for your analysis of my model. I’m sure if you looked at the house model, you’d find all kinds of funky stuff, but even after years of using SketchUp Make, on an occasional basis, I have a lot to learn with SketchUp Pro and LayOut.

And yes I did knowingly modify some dimensions. The lot dimensions are shown exactly as depicted on the lot survey which dates back to last century but is in fact the legally recorded info. I didn’t see a way to set them for hundredths of a foot which being able to show other dimensions in whole feet. And yes, I do realize that those edited values will not follow changes to the model, however, the lot is what it is, it isn’t going to change.

And yes, other edits to the dimension text are for placement for readability. When exported to LayOut the model dimensions work as I want. I tried to do the dimensions in LayOut but couldn’t get them to show as I wanted. For example, I could not get the 10’ value to be just 10’, it was either 9.75’ or 10.xx’ and I am using a vector format in LayOut, raster gave way to much pixelization.

I tried your <> suggestion but I guess I don’t quite understand how it’s supposed to work.

I am very happy to finally have dashed line capability in SketchUp but I still don’t understand why it was set up aa layer related. In my mind, a line style is a line style regardless of which layer, group or component contains that line.

Watch this animation.

  • I left the units at Architectural, which causes them to change to feet and inches so that it is obvious what happens when I enter <>
  • It might not be clear, but I double click a dimension’s text to enter edit mode for that dimension. You could also right-click on a dimension and choose Edit Text to get the same mode.


I suppose the drawing was based on modern, in-situ measurements not the historical ones, and that’s why you needed to modify the values?

And yes, many of us thought dash patterns should have been a styling aspect of edges, like material, and not a layer feature. But the developers evidently thought this way would match more closely to what people are accustomed to do in CAD (where there is no issue with layers not isolating entities because entities don’t interact until you tell them to, regardless of layers).

Edit: you could have both the modern and the survey measurements in the same dimension by entering something like “<> (179)” (without the quotes). The <> will retain the as-drawn value and the one in parens will be the old value.


It looks like quite a bit of work with no real benefit, at least for my needs.

When I created the plot plan I used the bearings and measurements directly from the recorded survey, which dates back to 1959. Bearings are in degrees, minutes and seconds as per standard surveyor nomenclature. However, in order to create the guides for the bearings I needed to convert to decimal degrees which ends up being 5 decimal places and is apparently finer than what can be done with SketchUp. I entered the lot border lengths in hundredths of feet (which can be done with SketchUp), just like shown on the survey. As a result of doing all that, I found that drawing the lot borders per the guides established for the bearings, things didn’t all gel with the survey. Hence I tweaked the dimension text of the borders to agree with the recorded survey and I show the bearings in LayOut as degrees, minutes and seconds so in effect the end result is a lot described exactly as shown on the official recorded survey.

For my needs, (drawing submittal to get a permit), the detail accuracy of the plot plan is not important (or relevant). What’s important is the description of the lot and locations of easements, setbacks, utility lines and the location of the structure on the lot.

SketchUp’s maximum display precision for angles is 0.001 degree, but you can input decimal degrees to more decimal places by starting an angle with the protractor tool then typing them in. They will they display with only three places and a leading ~ indicating that the true value is not exactly equal to the display, but internally the precision is kept to enough places that angular error should not be an issue at all. A 1 arc second error in a 180 foot arc yields an offset of about 1/8 inch, and even SketchUp’s display precision of 0.001 degree yields about 1/2 inch. So if you were seeing misclosures larger than that, either you weren’t entering angles to enough precision or, more likely, the survey data are suspect.


Great information. Is there a specification for SketchUp and LayOut somewhere?

Yes, I’m very familiar with the idea of starting a line or guide with some arbitrary value and then editing to the desired length/angle in the measurements box, but, I did not know about the display versus internal accuracy.

I created the lot layout a couple of times and I did find a few errors between the model I created and the actual survey map, so I created a “site survey” in LayOut depicting what I feel are the discrepancies in the “official” survey plan. Based on the info you provided I may try to draw out the lot again when I get time but for now, the site plan I have is more than adequate for what I need.

The difference I see in your process is that you select all dimensions and then make the change before hitting “Update selected dimensions”. That works fine for me too but what doesn’t work is selecting a specific dimension, say one of the 10’ setback dimensions, making a change to the text location (e.g outside > centered), and then hitting “update selected dimensions”.

It works using the Entity Info window but not in the Model Info window.