Floating Rectangles

This is my first rendering for an actual customer…I was trying to add the awning and the 2 signs to a photomatch model of his building. I have been plagued with issues and problems revolving around my lack of understanding the “language” of Sketchup and it’s bevvy of exceptions and caviats. But I do love the program and it’s output. WHat I am experiencing here is trying to “glue” the 2 signs onto the walls. They “float” around, sometimes going inside the building itself, but never "on’ the wall. If I can get them glued to the wall, I can resize them properly. Here is an SKP file, should anyone have time to look it over and critique my quandry. Thankyou in Advance. RoBhttps://app.box.com/s/zjd2wzabtrqhjgjf7y3490fgkm4t9v9s

You make them components, and in the save dialog, you set their “glue to” behavior to vertical faces. But the XY plane is what “glues”, so inside the component you’ll need to stand the sign up on the gluing side.

See:

Be sure to not (uncheck) them as “Always face camera”.

Thankyou Dan, Can you please expend on that thought a little
? I appereciate it. Sorry to be such a dummy, but I was born that way (LOL)

RoB

straighten up your signage so it is aligns to the blue and green axis and then you can place it on the side wall…

edit: your entire model is skewed to odd angle, is that deliberate?

john

No sorry. I believe that there is enough on the subject already in print, and covered by tutorials.
You are now armed with the buzzwords, so you can find the information you need.

John…The scewed angle was not intentional. So I straightened it and the
signs still “float”…Is there a “glue command” or a “place item on surface
command”? In this screenshot, both signs are still afloat. Please take a
look and advise if you get a minute. And thankyou. Happy Fourth of July!
RoB

Dan…I read articles all week and also watched Youtube videos. I turn to
the help community when I get so stuck and run out of things to try. I
realize you may be a little too busy, but perhaps one of the other masters
can shed more light on the subject. I am just trying to learn, nothing more
nothing less. Many may see me as frivilous, but these issues I encounter
are prohibitig me from finishing my first complete project. Thannkyou for
your support.

RoB

I answered this above, and gave you a link that has a screenshot of the dialog where the setting is made. Noone has clicked it, …

:laughing: (He’s British.)

1 Like

Dan, They already were componants, I treid finding a “save” option with a
“glue” selection, and cannot find it. Thankyou for your help, and
understanding Dan. When I think of “glue to”, I think of bolting the sign
to the side of the building. That’s all I have left to do.


RoB

You should have set them as “glue to” when you made them.

Ok so now, in the Components Manager, click “In Model” (little house) button.
Select the definition for one of the sign components.
Click the “Edit” tab.
See the “glue to” drop down control ? Use it.
See the “Always face camera” checkbox ? Make sure it’s unchecked.

Notice the “look” of this edit panel.
This is what the “Create Component” dialog looks like, that you MUST have used to make the components (by right-clicking a selection of entities, and choosing “Make Component”.)

Just by coincidence, it also looks just like the screenshot on the guide page I linked to above.
OH, here let me give you the link again:

So listen. If a component is not working correctly, you can move one of it’s instances off to the side, and explode it. Then correct it, select it all and right-click “Make Component” again,. And do it correctly the second time.

You need to practice with the Move tool, afterall, you just want to move those components.

In this case, gluing not really needed. To create a gluing component you would first needed to draw/set-up on some face before making the component. But you can work with what you already have. Just move the sign real close to the building - enough to appear to be touching.

To help you move, review the second tip written in the link I gave you. There are some useful options to lock the direction you can move things. There are 3 arrow keys that lock movement along the 3 axes. Just begin to move the object then click the arrow to lock the direction of movement along the axis of your choice. Here’s more on this inferencing

Now inference lock has been improved with SU16. In addition to Shift as shown in the old video above, the arrow keys can be used to lock axis direction - up for blue (z-axis), left for green (y-axis), and right for red (x-axis).

SU want to keep things square to axis by default. It took a little human intervention to tilt the sign off axis :wink:

1 Like

Dan…I looked everywhere, and don’t see a dialogue called “componant
manager”…componant is mentioned in different selections, but none say
componant manager. I should have told you also, that the signs are imported
PNG files. Does that make a difference? Thankyou in advance…I have to
finish this by Tuesday so I decided to work the weekend trying to finish it
up. And I have one more sketch to make but it will be a cakewalk (Photoshop
CC). >>>>>>my current sctreenshot>>>>>>

Rob Orizino

I refer you to my previous post:

http://forums.sketchup.com/t/floating-rectangles/27373/2

here is a link explaining what is going on http://youtu.be/9aOhUvbvfJU?hd=1