FlexTools Window inconsistency

Hi friends, new here to SketchUp and I purchased the FlexTools extension for windows and doors. I feel like I’m missing some fundamental understanding of the extension because it has been rather inconsistent for me. The components sometimes snap right into place and cut the walls just fine, and other times they just float inside the wall and I can’t figure out how to resolve it. I’ve tried using the arrow keys to lock in the plane but the component doesn’t lock in. You’ll see in the master bath that I was able to place and modify a sliding window above the tub. Now when I try to place another window, instead of snapping to the guides or the original window, it just floats in the wall. Once or twice it snapped to the outer face of the wall, but that then requires more work to flip/rotate/etc to be consistent with the first window, and even then I haven’t been able to get it right. HALP!
Floorplan 1.skp (5.6 MB)

Well, a couple things:

They want the walls to be components, not groups, so try that.

Install the windows from outside the component, not into raw geometry inside the group or component.

For as long as I can remember, using guides while installing native window components with gluing behavior never worked. If you snap to the guide, the window would flip out and not not glue to the surface. That said, FlexTools seem to work ok in that regard, so I’m not sure what you’re experiencing. Try the above two things first. You can try my old school approach which is, deliberately install it in the face but slightly off, and then drag it into the correct place snapping to the guide. Resizing FlexTools windows is done with the scale tool.

Be aware that you can’t butt two Flextools windows together and form one opening. You either have to leave a little bit of wall surface between, or you have to make a custom multi-window component and make it into a cutter yourself.

Hi there,

I just happened to see this post! Best to write in the main forum thread at: FlexTools Extension or contact us at Contact – FlexTools

  1. The floating issue sounds like what RTCool mentioned, and that is gluing. When placing a window component it will glue to the first plane it is placed on, and you won’t be able to easily move it away from the plane. Gluing is currently necessary for the wall cutting to work.
    After placing a window, preferably from the outside of the building, to move it in and out in relation to the wall, change the ‘Inset’ setting in the component options window.

  2. If you need to copy a window to a different wall, that is not on the same plane use Copy and Paste, and as RT said, it’s best to place it anywhere on the wall, and then move and scale it to the exact position where you need it.

  3. I looked at the sliding window above the tub. There are hidden handles there that are sticking out of the component’s bounding box, and this causes the scaling to not work correctly. To solve this (for now):
    Go to View > Turn on Hidden Objects.
    Double click into the window and either delete the handle components, or set their height to 0 which will center them vertically. (see image below)

Alternately you can set the window’s height manually in the component options window (without the scale tool) and then place it where you need it.

In a future update I’ll make sure that we fix this! so the handles won’t stick out when the window is so narrow.

  1. You’ll notice that on one of the walls in the model, the reveals of the windows aren’t showing correctly. This is happening because one of the walls faces is backwards. To solve this you must make sure that all wall faces are facing out (white on the outside and blue on the inside).

Turn on Monochrome view to see how faces are oriented in the model.


Right click on the blue face > Reverse Faces > Select all the windows and hit Refresh

  1. Yes, it is recommended to have the windows placed outside of the wall component.

Any other questions, I’ll be glad to help.

BTW, I couldn’t understand why the model was so slow when orbiting. It took a while but I found the culprit. The door handles you’ve used in the kitchen are very heavy. Turn on: View > Hidden Geometry and you’ll see 6000 lines just in one little part. It would be better to make your own simpler handles instead.

Another thing that would help the orbiting speed would be to turn off profiles. See image:

Thanks so much for your input!

1 Like

Thank you SO much! That was super helpful!

1 Like