FlexTool Problem with Multiple Windows


I have a double wall on which I’m trying to add 5 identical FlexTool windows.

I created a component that included both walls. I selected that component, dragged a window from FlexTools to the wall, scaled it and moved it along the green axis.

When it got to the right hand side, I pressed /4 Enter. Normally that would have given me 5 of whatever I started with. As you can see from the animated GIF, it does no such thing.

What should I do next?

Peter Enns

Slash 4 Enter Not Work
LH Hexagon with side walls & 10 windows.skp (184.8 KB)

I thought it was x5 to get 5 objects ?

It does look like the windows are being copied. But smaller or in the wrong position/orientation.

There seems to be an issue with the file you attached. I don’t see anything in the model space.

1 Like

I could have used 4x (4 + the original one). However, in order to have everything evenly spaced that would be more time consuming. It’s quicker to use / 4 Enter.

BTW, the first time I tried it, the entire wall system had been selected. I tried to make the entire model again. This time I forgot to select the wall system. As you can see from the attached PNG file, it worked.

Peter Enns

1 Like

I’m not sure what went wrong (or right), but one thing I can warn about with FlexTools cutting objects (and even native cutting objects for that matter) in walls while using guides is that your window component either snaps to the wall face or the guide line but not both at the same time. In the case of the latter, it won’t cut the wall and in fact usually flips upward. That’s not what I’m seeing in the GIF you posted, so IDK if it’s relevant, but that’s what I think of when I see guides on a wall face for positioning windows. What I’ve had to resort to is deliberately placing the window in not exactly the correct location, and then using the move tool to adjust it. Once one is installed, move/duplicate should work.

That wouldn’t work with a “divided by” array…

You aren’t moving the window in the same plane, so window is not cutting the component because it’s not glued to it.

Hey Learned One,

Thank you very much for that FlexTools warning. I took it to heart & now things work perfectly.

Peter Enns

1 Like