Flex tools component finder on second screen

I use Flex Tool’s component finder which is excellent and I would suggest that every one that is not using it give it a go. It’s very quick and easy to find what you want and seconds count.

Here is the issue. every time I open SketchUp I can not get the component finder to stick to the second monitor like native SketchUp trays do. I have to manually move it each time to the second monitor on opening SketchUp. While this does not take long, it’s just something that could be fixed to improve workflow and reduce the annoyance.

All the best

1 Like

Probably something only the developer of Flextools can fix.
Maybe you can contact them?

Just hit them up on https://flextools.cc/, there’s a chat you can use to bring this to their attention.

Thank you,
I am led to believe this is a Sketchup issue, not a Flex tool issue. I am not a programmer so I don’t know. So I thought I would raise the issue here.

I believe this problem isn’t specific only to Component Finder, but to all windows that use HtmlDialog.
This happens for example with Sketchup’s ‘Extension Manager’ window as well.

Curiously with the older WebDialog windows this doesn’t happen.

I use two screens as well and would love to see this fixed.

Sketchup Programmers.

Can we please fix this?

Many thanks

Maybe @colin knows who to make aware of this issue…

I am not sure whether it is a Flex Tools problem or a SketchUp one. What happens if you tear off one of the built in toolbars, Solid Tools for example, and put that on your second screen? Is it still there next session?

In your first post you mentioned native trays, and those behave differently. I want to see what happens with native toolbars.

Hi Colin
I tried just that. I moved the solid tools toolbar onto the second monitor and it stayed put when reopening. However, Yoni spoke of the HTML dialogs, are these the same as the native toolbars?

Thank you for entering this thread.

@Hilliard_Scott Can you think of something where extensions that have palettes can show them on a second monitor, but HTML dialogs might not be there next session?

I have to say if I open a Medeek dialogue box and move it to the second monitor and then close it down and then reopen it within the same session of Sketchup it does stay in the same place on the second monitor. The same is true if I close down and reopen SketchUp, the Medeek dialogue box stays where I last opened it on the second monitor. This makes me think why does the Medeek extension do it and not Flextools.
Yoni, can you check this out, please?

many thanks

It’s possible that the windows are not saving their positions, or that that windows are being created with some relative position settings. Is this Windows or Mac (or both)?

Weirdness has been reported when the external display is connected via a dock and also with some notebooks when the external display is connected via a certain type of interface (Looking back in the Technical Problems category, HDMI connections had issues and it is suggested to try USB3 or mini display port. Main issues previously with this were the main SketchUp application not reopening on external display and display scaling issues with interface elements.)

Both my monitors are using HDMI connection into Nvdia Gforce RTX2080Ti.
I use a windows system.

Just stretching this topic a little. In Layout, I have my scrapbooks on the second monitor and I can not get it to remember the width of the tray on opening. I have to adjust this every time on opening Layout. As the scrapbooks tray needs to be as large as possible to see everything the width of the tray is important. I restrict my paper size within scrapbooks to A3 so that I can just about read everything I need to read within my monitor space.

Maybe try a Display Port cable to the monitor.

I discovered today that this happens to me in Windows when the 2nd screen is marked in the display settings as the main display.

Right Click on the Desktop > Display Settings

This was my arrangement:



Solution 1: If you change it to the default where the 1st screen is marked as the main display the problem disappears.

This solves the problem if you don’t mind which screen is marked as the main one.
In my personal setup, I need to have the 2nd bigger screen marked as the main one, or else I have problems when maximizing Sketchup windows that use the older Web Dialog interface (Dynamic Components windows…) that won’t maximize past the dimensions of the first smaller screen.

Solution 2: If it’s important for you to maintain which screen is marked as the main one - you can try swapping the cables between the two screens so they will change their numbers. I tried this now, but it didn’t solve the problem until I also swapped the positions of the screens - both in the Windows display settings and in Reality! go figure.

You might have to do only one solution or the other or both…

The bug
I’m not totally sure, but I think this is what is happening: When a screen is marked as the main one, Sketchup considers that main screen to always be on the left even if it’s set to be on the right side in the Windows display settings. If the main screen is on the right, when you close an HTML Dialog window on the left screen, it won’t open back again because there is no screen on the left as far as it knows!?

I dunno… I’ll let the Sketchup team figure it out! :slight_smile:

1 Like

Nice explanation Yoni. Yes, this has been reported for several release cycles.

Regarding main screen on the left. Windows maps out screen coordinates with the origin on the left, so if your desktop is extended onto the 2nd display we would expect that the 2nd display would naturally be to the right of the main display.

However on my desk I have the main (internal) notebook display on the right (1) and the external 2nd display on the left. I have no problem moving the mouse between the 2 displays, but found it best to have the taskbar cloned onto both displays.
I have since I think SketchUp 2017 not been able to have SketchUp open on the 2nd larger external display which I have connected via an HDMI cable. (I just never got around to buying a display port cable.)

So, yes I think that this display issue has been noticed and reported since SketchUp stopped supporting OpenGL 2.x and went v3.1 minimum. I think this was the 2017 release.

I’m not sure whether this is a SketchUp issue or a Windows system issue. Can anyone show that this issue does not occur with other applications ?

1 Like

Thank you all for your replies.
Yoni, Thank you, I have managed to swap around my desktop and it works as expected now.
My screens are the same size and use HDMI. I had the main screen on the right (monitor 1) and the extended screen on the left (monitor 2) As I say I have reversed this now and am learning to work on the left monitor now. The transition is harder than you think.

All the best

1 Like

Heh, I’m going through some withdrawal symptoms myself :slight_smile: