Can't drag trays to second monitor


#1

Hey guys - PC noob again.

I’m trying to organize my trays and I like having some on the 2nd monitor. When I try to drag a tray from SketchUp it partially goes into the 2nd monitor but then “hangs” onto the edge of the 1st monitor and won’t continue all the way. If I let go then it disappears and I can’t get it to show. It just disappears into nothing and it shows on my “Manage Trays” list but can’t see it anywhere on either screen. I can’t even delete it - it is grayed out!

Just as FYI - this works with Adobe products - I can move the trays to the second monitor without issue. Is there something in the settings I messed up?

Also - to avoid some questions - I’ve already reinstalled with Admin. Thanks for any help.


#2

Should have clarified. This is my first time trying to add trays to a second monitor on Windows. I had it set up this way on my Mac. Thx.


#3

LOL…I must have some sort of bad luck here.

I decided to close SketchUp and open it again. Thinking that might “fix” something. I did and then there on the second screen is the Tray! Yay! Until I click on it then it disappears!!!

Looks like jokes on me. I can only laugh now at some of the issues I have.

If anyone has some insight - I’d appreciate it.

Cheers.


#4

What happens when you try to move the tray using win+shift+left arrow?


#5

Hey RL,

I am using virtual desktops (my old habit of using desktop on Mac). When I click win+shift+left arrow the entire SketchUp workspace moves to the second monitor!

Is that what you expected? Not what I expected.

Having said that, the tray is still not there on either monitor. Still shows up on my list. I can even click on the top bar of the Tray and it shows me all three items checked. When I uncheck the tray that is lost nothing happens.


#6

Just double checked “Settings - Display”. I have “Extend these displays” selected. Works in Adobe. Is this the correct selection?


#7

Reset your workspace


#8

I’m pretty sure your virtual desktop is the problem. Sounds like you have created another workspace rather than a second monitor.


#9

Thanks Mics. That worked in showing the tray again.

But can’t get it to drag to the second monitor.

Box - I think you are right. I followed the instructions on setting up a virtual desktop from the Windows instructions. I’ll try to do a search and see if I find some info.

Again - confusing thing is that it works right in Adobe products (Illustrator, Photoshop) but not in SketchUp!

Just as a test I decided to restart and not open any virtual desktops. Deleted all of them and started SketchUp fresh and it still had the issue with the tray not moving to the second screen and disappearing if I released it.

Any other thoughts would be greatly appreciated! Thanks guys.


#10

Looks like there’s not much info. Is this something that I bring up with SketchUp technical support and are they much help?


#11

Are you on Win 10 Pro or home?
Are you extending the display or duplicating the display?


#12

Hey Mic - Windows 10 Pro.

Mentioned earlier that I am Extending the displays. Works fine for Illustrator and Photoshop.

Recent build (last 14 days) with all drivers updated and working correctly.

Thanks.


#13

Have you ever deleted a virtual desktop while SU was displayed?


#14

Hey Mics…as I get older my memory fails. Just started messing around with virtual desktops yesterday. I’m pretty confident that I didn’t delete a virtual desktop until after I was having problems with SU and was trying to trouble shoot.


#15

I know you said other apps work fine on the extended monitor so I assume your mouse curser isnt set to snap mode. Does any portion of the SU toolbars show on the extended monitor?


#16

When I drag it over, it acts like it’s going to work. By that I mean that it slides over to the other monitor like normal. But the minute the cursor reaches the edge of the primary monitor, it disappears and the whole box disappears. If I let go that’s when I lose it. If I keep pressing the mouse button I can drag it back to the primary monitor and the tray appears again. 2nd monitor is set to the right of the primary.


#17

Im no guru but I was reading about it and had some time (procrastinating) Try opening display settings> multitasking and untick the snap settings. I like the idea of extended monitors but my computer is a notebook and has a different resolution than my monitor so Im not real familiar with extended mode.
DO NOT do anything you don’t think you should based on anything I tell you :slight_smile:
Perhaps try the top option under snap first…the one about arranging windows automatically. That was the one I was reading about things getting lost when dragging


#18

Mics…I really appreciate your help.

It almost worked! lol

It is the most bizarre thing. So hang with me. I drag the tray over to the right. Again - it hangs when I reach the end of the primary monitor. Just for kicks I keep going all the way to the right edge of the 2nd monitor while still holding down on the mouse button. Cursor moves but tray disappears. Drag the mouse to the left and at exactly half way of the 2nd monitor the tray appears on the very right edge (not on the cursor). I can release the mouse and go back to the tray and drag the tray into to the page of the 2nd monitor…but only to the halfway point. If I do that it disappears again nowhere to be found. LOL.

So I can have trays on only the right side of the monitor. Gotta love PCs!


#19

Check the virtual position of the monitors.
Right click on the screen and choose display settings.
And see if the screens are aligned correctly and there isn’t another one showing in between.


#20

https://support.microsoft.com/en-us/help/181691/some-programs-are-displayed-off-the-screen

Theres a couple of suggestions listed on here.

This leads back to the question about having deleted a virtual desktop while SU was displayed.