Component Finder Not Loading

Hi All,

I have been using the FlexTools Component Finder Extension for a while in SketchupPro and today, all of a sudden, the component finder pop-up box will not load. When I click on it, nothing happens. I have tried a computer re-start and re-installing the extension, but to no avail, has anybody experienced this before?

Best

It’s possible that you use multiple screens and have recently changed the position/setup of your monitors. (Maybe the graphics driver updated.)
In that case perhaps the Component Finder somehow placed to offscreen.
You may try the “magic key combination” to locate the missing dialog (Similar to this):

Preferences Dialog won’t open / Explaining the magic key combination - Tutorials - SketchUp Community

Hi Dezmo,

Thanks for this.

I think you’re right. I usually connect to a secondary monitor and used the component finder on a remote desktop on there yesterday. Now, I am back to the laptop, but even with the above, can’t seem to find it.

Liam

Try to Follow this guide exactly.

  1. Make sure SketchUp is not running

  2. Start SketchUp and wait “enough” that fully loaded.

  3. Click on the Component Finder as you usually start it. Do not click more or hit anything else in a keyboard, just do the remaining steps below as written:

  4. Hold down the ALT key. Hit SPACEBAR.

  5. Release ALT key

  6. Hit M (Move). (Note: assuming you have English windows otherwise you may need to replace “M” with a localized start letter, e.g. “L” in French)

  7. Hit one of arrow keys

  8. Move your mouse around (without pressing any mouse key) until you see the missing window.

  9. Press left mouse button on the desired place

Some toolbars cannot be moved this way, you have to move the screen itself to find them. You can use the system display settings to move them around.

1 Like

You are right, some toolbars cannot be moved this way.
If i remember right, Component Finder is using HtmlDialog, that is “catchable”… (I need to check that on my other computer)

1 Like

thanks for all your help, Dezmo!

Tried that too and no avail - so odd!

Grateful for your advice.
Liam

1 Like

Scrap that - in re-attaching a monitor and using your method here, it’s worked!

Thanks so much.

Liam

2 Likes