2019 Sketchup Component window not loading when make component

When I try and make a component, I get axes lines but no dialog box. I thought it could be a window placement issue but doesn’t seem to be the case.

Here is what I’ve tried.

  1. Unload all extensions I’ve added leaving only the SU Defaults
  2. Repaired my install of Sketchup 2019
  3. Reinstalled Sketchup 2019
  4. Reset Workspace

None of these options have helped, and when I have the axes lines, I’m unable to click anywhere on the screen. I can hit Esc to exit it thankfully yet it’s really messing with my workflow. Any help would be appreciated.


What happens if you hit Enter?

Have you been using more than one monitor?

I use three monitors, and when I hit enter, it seemed to exit. Maybe I’m missing something. New to the 2019 version used to see a dialog box asking me to name it and select some options.

Now that I’m looking more closely at it, you may have just solved my issue. Although it does not pull up the expected window, it seems to be loading without a name in the entry info on my tray. Is that how it works now? Think I can then change the name on that and then find it in the components tray window to make the changes. Seems like extra steps but if it works, I guess I’ll survive.

Thanks for the feedback, please let me know if I’m missing anything.

Select Make component, then hit alt and space together, then m then tap any arrow key then move the mouse without clicking until the Dialog comes into view.


The Create Component dialog should still be displayed. The reason I asked if hitting Enter worked is to see if you were actually ending up with a component. That would indicate that at least Create Component is creating a component. (This isn’t anything new from previous versions either.

Try doing what Box suggested to return the dialog to the screen.

This worked for me. Thank you so much. I was going crazy! Still don’t get what happened. Just happy it’s now fixed and I know how to fix it next time.

Thank you so much Box & DaveR

It just means the dialog was lost between screens, that sequence of keys grab hold of it and allow you to move it into visible real estate.

1 Like

Didn’t know there was space between screens. Learn something new every day. Thanks again.